summaryrefslogtreecommitdiff
path: root/dev-python/twilio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/twilio
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/twilio')
-rw-r--r--dev-python/twilio/Manifest3
-rw-r--r--dev-python/twilio/metadata.xml8
-rw-r--r--dev-python/twilio/twilio-3.6.9.ebuild32
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/twilio/Manifest b/dev-python/twilio/Manifest
new file mode 100644
index 000000000000..85a136bf4826
--- /dev/null
+++ b/dev-python/twilio/Manifest
@@ -0,0 +1,3 @@
+DIST twilio-3.6.9.tar.gz 226151 BLAKE2B 841e37385b3d11e5423dcaf813e8568da204f9f34cc381b26869517ace2781db9aad0c6ab243a72b2f5144ef1ef103676ff5b9f5f95b38e9cc38a7f11c880ec5 SHA512 f4e0f13e3f12ae8e15817a285a4388859b458ba7759acce4d5f6ee425bd6a06742bf271a01e1cc5140d63bc599828b940f1e96a6ed7f5744c1c9eaef2dd65b29
+EBUILD twilio-3.6.9.ebuild 769 BLAKE2B 4ce6d7e593f197b3677ba13d15493eee4667f359465aa534da154af2b05d65735233f7d287eb7b29fdaa892ae81ec439cc61f7b04c931d9d5783788021b84326 SHA512 9c21e40390f4243e6be0ad51a0ef71712cae98690e41f59250630173eb82958ce9f424b0ec5b380fe1cbecf821305e6a9cd5f1c73dc1284f6e29462d30f1f286
+MISC metadata.xml 257 BLAKE2B c32821ae545a6d09172ee687af7af45673681c792c5b8e1843265ad2da114563ae3f6fdaae395973ff8e56d4f1e14c3eb3134309aa0bf71d1aad96e28fd1d44c SHA512 02a24ffac80ef671327118a115df5c90d0e6456680e2aba09356aea600791be6bf7dd7d6a79cf4a91180a3d4528899075f4558ebe382f8e8b112413960efa05e
diff --git a/dev-python/twilio/metadata.xml b/dev-python/twilio/metadata.xml
new file mode 100644
index 000000000000..5676c411dfe5
--- /dev/null
+++ b/dev-python/twilio/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">twilio/twilio-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/twilio/twilio-3.6.9.ebuild b/dev-python/twilio/twilio-3.6.9.ebuild
new file mode 100644
index 000000000000..d6ce9dbff2ef
--- /dev/null
+++ b/dev-python/twilio/twilio-3.6.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Helper library for the Twilio API"
+HOMEPAGE="https://github.com/twilio/twilio-python http://www.twilio.com/docs/python/install"
+SRC_URI="https://github.com/twilio/${PN}-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+CDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]"
+
+RDEPEND="${CDEPEND}"
+DEPEND="test? (
+ ${CDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tests || die "Tests fail with ${EPYTHON}"
+}