summaryrefslogtreecommitdiff
path: root/dev-python/tweepy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/tweepy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/tweepy')
-rw-r--r--dev-python/tweepy/Manifest5
-rw-r--r--dev-python/tweepy/metadata.xml12
-rw-r--r--dev-python/tweepy/tweepy-2.3.ebuild52
-rw-r--r--dev-python/tweepy/tweepy-3.5.0.ebuild52
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/tweepy/Manifest b/dev-python/tweepy/Manifest
new file mode 100644
index 000000000000..6365170eddd5
--- /dev/null
+++ b/dev-python/tweepy/Manifest
@@ -0,0 +1,5 @@
+DIST tweepy-2.3.tar.gz 52352 BLAKE2B 6853f133e73d8a97d5a2326ef6c877a527fad87ba9767e6ee218efcb84f6b8332d4f66b044b572987e71d4d9dd8a7b743c7976cfa9947101f0df5c6f9de5d1c4 SHA512 23317a507174e108cf8d13232aa467d892aba1789ee4f610eef4f5503b045841b5c85e8ae63ddcfd1e07178afbf3bf9f4a9fed939426411a8566f1c949b9b831
+DIST tweepy-3.5.0.tar.gz 24348 BLAKE2B ea9d96abe4f364e1f77a97ce28fcd4fca3224ab307698e59a834c20becfa53ab68851e638946085431ef2edc1a4e3bf4f42a113c2ac41561930b7f4638e5d6c4 SHA512 cf87f0b7dea0ca444c17a3fdb9c2ebef814683c110511876c1997630b3202393276d3dd2de3b37fc21eb7a15382d22cc886109bda5a11b3d06a08081704c8c2a
+EBUILD tweepy-2.3.ebuild 1144 BLAKE2B 108f61f6a1a81212482fe7283c72c84c1cbb5e8abbe259831e97a985ad48aebce45bb42bb12e0ad3034cfae28d7e15b0eafb4831abbe9335928162872a58ba10 SHA512 9a1d6835ceb7e476d07cf98aee251701616d0de197b9c79822ff830cf457edda0e209b9e81af03aac875f001fe1d6f44b180d78d29f3b2ff012963132806cbbb
+EBUILD tweepy-3.5.0.ebuild 1224 BLAKE2B 589bbe0b502141134b009247f8e641b40a21dfd47ad5422f553cb762daa94dc30760f705cbedb9036eb9954db7f3a50c24a66dbb9438572e7faed869f5c110b1 SHA512 6d7e5e4bc68f5ed777804c5a277d4a2a03a005e7884b8c7ddded03219b6b0e3eb1b765cb43508fe28b310ebc78d0ba7987f53790822c09ea80d05d1c45d16ef7
+MISC metadata.xml 374 BLAKE2B 54949ade0005d71f03bcbf3c84676c9a8b6b10420c8b28ac1e2e27b772b4cc685d3d88d9fce150c3f8a46b137ee4c3441cb4eb1925487f4e42858b73b2e1596e SHA512 e2785876cc350cb7130905648a4f9013fc79c286697c6fdfac203678ff79217383fad2c4d4d2caa42107d83c6cc29ae0d149acea16d74aab804a3039a3e143fe
diff --git a/dev-python/tweepy/metadata.xml b/dev-python/tweepy/metadata.xml
new file mode 100644
index 000000000000..0ee41d2f84f8
--- /dev/null
+++ b/dev-python/tweepy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tweepy/tweepy</remote-id>
+ <remote-id type="pypi">tweepy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tweepy/tweepy-2.3.ebuild b/dev-python/tweepy/tweepy-2.3.ebuild
new file mode 100644
index 000000000000..d348cf079cc8
--- /dev/null
+++ b/dev-python/tweepy/tweepy-2.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A Python library for accessing the Twitter API "
+HOMEPAGE="https://www.tweepy.org/"
+SRC_URI="https://github.com/tweepy/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+# online tests
+RESTRICT="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/httreplay[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Required to avoid file collisions at install
+ sed \
+ -e "/find_packages/s:]:,'tests.*','examples']:g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v \
+ tests.test_api tests.test_streaming \
+ tests.test_cursors tests.test_utils || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/tweepy/tweepy-3.5.0.ebuild b/dev-python/tweepy/tweepy-3.5.0.ebuild
new file mode 100644
index 000000000000..8a4aa583abb8
--- /dev/null
+++ b/dev-python/tweepy/tweepy-3.5.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for accessing the Twitter API "
+HOMEPAGE="https://www.tweepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RESTRICT="test" #missing in tarball
+
+DEPEND="
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+RDEPEND="
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.3[${PYTHON_USEDEP}]
+"
+python_prepare_all() {
+ # Required to avoid file collisions at install
+ sed \
+ -e "/find_packages/s:]:,'tests.*','examples']:g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v -c tests/travis-tests.cfg || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}