summaryrefslogtreecommitdiff
path: root/dev-python/turbolift/turbolift-2.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/turbolift/turbolift-2.1.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/turbolift/turbolift-2.1.3.ebuild')
-rw-r--r--dev-python/turbolift/turbolift-2.1.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/turbolift/turbolift-2.1.3.ebuild b/dev-python/turbolift/turbolift-2.1.3.ebuild
new file mode 100644
index 000000000000..ad4f95a505b8
--- /dev/null
+++ b/dev-python/turbolift/turbolift-2.1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+# tests are not distributed with the release tarball
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Openstack Swift sync/backup utility"
+HOMEPAGE="https://github.com/cloudnull/turbolift/wiki"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools
+ test? (
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/prettytable-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/cloudlib-0.5.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} -m unit discover turbolift/tests || die "failed testsuite"
+}