summaryrefslogtreecommitdiff
path: root/dev-python/trove-classifiers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-23 04:04:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-23 04:04:37 +0100
commitfd93fe10d9e6c855fed8e1524b2d2d64d2085570 (patch)
treeef70885add7d9276bc4f5e8b56c784bc974b3e0b /dev-python/trove-classifiers
parenta15e8dc7444560123d7d4be1bccb19afd5b611d0 (diff)
gentoo auto-resync : 23:10:2024 - 04:04:36
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest2
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.10.21.16.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 32bdccfe7437..ad08867c529d 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,3 +1,5 @@
DIST trove_classifiers-2024.10.16.tar.gz 16113 BLAKE2B 7ab9b0d16d93abeb4cf272bacdbf946cb85f3544c028860bfa2163f883e62868fb5a8356186dd59d2fec98b8dd06578aea0a60f02304f2ce555d7fa6fd5bc283 SHA512 7d67947c12e2fbe8a3d380e50e22671cc538593e0bf752955b84f74018c364dcc56553727dc53a540da713df5db73601acdc1e1cd608f55a968b9ec48a04d9ee
+DIST trove_classifiers-2024.10.21.16.tar.gz 16153 BLAKE2B 9170a2f78b41d2d6793a5bbf7df7ce2ae4c1d70a193a92874bf74cad5a083d8153a9cd8ae42c85da3cdedc690c485aff8d864626efdb52965301f2a377ebb048 SHA512 4fca7cc5d172ddcb210bfbd6e993fc3d7243887762ba37c05aca3d6c5fcece8f573372704160c8048eb39c68d284fe808ca289c8c07564b06334bed6bafdc61e
EBUILD trove-classifiers-2024.10.16.ebuild 1128 BLAKE2B e4e44e536c58179919399f86d99114c4ace9df439d6df760844862d49a961223778b3b64a748a519018439425407e206626060b8f0b7ac760f7246e48eaf53a9 SHA512 2142c9d8eb3310abcdbb9cf96e34a034e1782bc2c7e76179c10c14acdc7072202773e9767f43e20af771bb2ba9e67139815525322c824b40b17b0f5cd0010380
+EBUILD trove-classifiers-2024.10.21.16.ebuild 1136 BLAKE2B 5f68bec1e8a21b13d09d94604a9aa970b81339d5fca61a25efd4a3ea91520c2631f69eb87683cb0cab3b1492ee08e3217b4a98b141500915532b62b21b58fdc4 SHA512 915bb79fa7d1e088eb02d37dafba8958396ec3fb5eccad63f5c3f72160b9e93642c1af9f5732b429fca52c5ec4c0de9c0a580448de4d7307b44c519c29493a69
MISC metadata.xml 385 BLAKE2B 0d679ace6575dab100af9918e8b6dbde2f70cbf556c23ee667d68f69c6dd07887e43a513a73e60849a7a4b88cb26d4cd85b4cb905b926ee3832161c663adc9c0 SHA512 977bc86d4fb2dfcc887fd8d4038b8ac76cb0f4783424d3ab0857256afaf5dacf4e45c0d2a9166daa854be1dc8faba4a10c4718c557b983a1c7bb0a33fcd61f41
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.10.21.16.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.10.21.16.ebuild
new file mode 100644
index 000000000000..b19f32b12f71
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.10.21.16.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} python3_13t )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}