summaryrefslogtreecommitdiff
path: root/dev-python/trove-classifiers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-09 13:01:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-09 13:01:22 +0000
commitc6985b401141ea8b5ec4b95c4ad3a5a21ef32571 (patch)
tree56249d49d47e3dde9d3298ed175d983defedf23b /dev-python/trove-classifiers
parent6790f1eddc7029fda1a6bae94751a4ff1eb57776 (diff)
gentoo auto-resync : 09:01:2024 - 13:01:22
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest2
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.1.8.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index dabbbb12ece0..9be309e83a80 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,3 +1,5 @@
DIST trove-classifiers-2023.11.29.tar.gz 15918 BLAKE2B 3e216aa24a458f5c65a20b2589dff34c382c3e1ccba5274377b09bcc254fafb077dfd3f82b0f1c998a9c34b20f35eca27bd7d8103b631a03eb87a9c1525c057e SHA512 fdeb6bbddbb3ad640112827b55f4b0a2201c79e2a4013d2d621bf0a6168d87861ad1802b0805747fc7d9e8be7e1954d58b83fd4fde6f3394cec2fa3aa88f0dca
+DIST trove-classifiers-2024.1.8.tar.gz 15943 BLAKE2B f0a4ec5439415d53d81297001aac2b4ffc3da0e2c5492acb9a3ed23fba9e7c7ea1407cfa2f8291ab0b8ea7f1dd985cdd86a1b82e71b0223c88ae73bcc7ce63cd SHA512 3a86f54fd432b7d176cc7740a6a171eb9cdef339633b023ab81f5f8e68a7bae5ebb2d49c82aaec53f0f865c84234ac9506de45f76c3b9be18d57f5fcfe3afe73
EBUILD trove-classifiers-2023.11.29.ebuild 1142 BLAKE2B abe0c6eb91f275425a292196f6b76bc580f6c7e17ccc98148e1a85bbd869997428c5ff5ca65b771408d3401e29479d3264865ac43eb0169f36935f913da9dba1 SHA512 50a9e00c11843a13fdba5e026a71bd249a277a8e38e11e5e0239297af627c9a4aa3f08bb29862aa739d0a08f1ed1a45fbb6c3786be4f4fce5d0ceef3e07385b4
+EBUILD trove-classifiers-2024.1.8.ebuild 1150 BLAKE2B 0e70586246456bb6664decb5e668d0fc9753d0498fdeb7299b4b83142d2f6fc79b4037cc3ef2e25dc11e36a4462453ae9dfea4d93daf64cf03a74c78c3732475 SHA512 de49ad590035b61d40e1265baf607379b6bfbf671b31cd1921e6ba70253fc53fc860d140d0bc6ef3e721469377a81bb4937d53ee5bd41083172cd8dc7e7a9f38
MISC metadata.xml 385 BLAKE2B 0d679ace6575dab100af9918e8b6dbde2f70cbf556c23ee667d68f69c6dd07887e43a513a73e60849a7a4b88cb26d4cd85b4cb905b926ee3832161c663adc9c0 SHA512 977bc86d4fb2dfcc887fd8d4038b8ac76cb0f4783424d3ab0857256afaf5dacf4e45c0d2a9166daa854be1dc8faba4a10c4718c557b983a1c7bb0a33fcd61f41
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.1.8.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.1.8.ebuild
new file mode 100644
index 000000000000..3172a692bdd9
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.1.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}