summaryrefslogtreecommitdiff
path: root/dev-python/trove-classifiers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-11 06:32:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-11 06:32:47 +0100
commit900988746a1a7412b5d0f0025e9f892233a417ff (patch)
tree80904da68f8e4e3ef838fb178a99ad11c54ccd3b /dev-python/trove-classifiers
parenteccbaf6d01fb4a73c18778fa551e74960b1e0419 (diff)
gentoo auto-resync : 11:04:2024 - 06:32:47
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest2
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.4.10.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 8fd0c0565024..e1e32154f41a 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,3 +1,5 @@
DIST trove-classifiers-2024.3.25.tar.gz 16040 BLAKE2B 001a307d041e76213f3d2d115a10467b8434afecb0dc268ed9a1943aa7961c9021b49794a593102372c41b6776f3e513db44f680dda700c9897f65ef593ec860 SHA512 3b1d0c08d9a90bfe2314b092270677397d5150f0b641dfaf6ffda7a3447b898ea2c1d2dceab0f61ddceeb6b42945aec19e7a1028bf72ac3a119454f66945db7c
+DIST trove-classifiers-2024.4.10.tar.gz 16036 BLAKE2B bfd0ae5e3e1dc2dab67e66dc9cdf90b3ff789d00fff5f13ddf8974736adf3e37c505488d4aea32b0c4b43a6d77617e9a0672def2e66baf813734b1e3bebb8bd3 SHA512 2705ea82869bb3092dd37c817d5263955249b44ad64c0fcedc523ecc78eaeb2a327500adbafe70c5d08b5961bf8095748e34a0daa1a2ba8db3fa27e1a35a645b
EBUILD trove-classifiers-2024.3.25.ebuild 1142 BLAKE2B e5642e65771464cd3cd1c89e6b66f99aa46daae2d695cd64e4b4949c86c4554f82a323e5fb2321fc3acc0862ece82acc351cefae30c42c867161ad674b21ffcd SHA512 cc61fe3cd7599e5f8a12e42fc63bc22e0f50a58027845b71f179503c7bc7d497d2f26fc8f41eff9b1cd5f5f0c072140ecb270dbbab016fa64b811e94a677f006
+EBUILD trove-classifiers-2024.4.10.ebuild 1150 BLAKE2B 0e70586246456bb6664decb5e668d0fc9753d0498fdeb7299b4b83142d2f6fc79b4037cc3ef2e25dc11e36a4462453ae9dfea4d93daf64cf03a74c78c3732475 SHA512 de49ad590035b61d40e1265baf607379b6bfbf671b31cd1921e6ba70253fc53fc860d140d0bc6ef3e721469377a81bb4937d53ee5bd41083172cd8dc7e7a9f38
MISC metadata.xml 385 BLAKE2B 0d679ace6575dab100af9918e8b6dbde2f70cbf556c23ee667d68f69c6dd07887e43a513a73e60849a7a4b88cb26d4cd85b4cb905b926ee3832161c663adc9c0 SHA512 977bc86d4fb2dfcc887fd8d4038b8ac76cb0f4783424d3ab0857256afaf5dacf4e45c0d2a9166daa854be1dc8faba4a10c4718c557b983a1c7bb0a33fcd61f41
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.4.10.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.4.10.ebuild
new file mode 100644
index 000000000000..3172a692bdd9
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.4.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}