summaryrefslogtreecommitdiff
path: root/dev-python/trove-classifiers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-03 08:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-03 08:05:42 +0100
commit8435c842b9e8fbb2bcc80397ab3aa655000459e2 (patch)
treeb74558e80643a8f074c501e8b4bf7f50f7155455 /dev-python/trove-classifiers
parent5c5e9714c851027611cb726a76ebb8be6d48cbdc (diff)
gentoo auto-resync : 03:07:2024 - 08:05:42
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest4
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.7.1.ebuild42
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.7.2.ebuild42
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 5281248d1450..62291ca34779 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,3 +1,7 @@
DIST trove_classifiers-2024.5.22.tar.gz 16050 BLAKE2B e9909972067f1ec825a127801483aa5d6c47bc7c7442bfc4490eec2628003fa0d25362ad10255b20174beb93cfd382df43a948c73c9c8834307d660897d8162f SHA512 34fd1e47f41563e6e9471ae029897d96fec8119368a1bfd8b8982b26c56a1e9e0b154dcd155b401cf537cbfba574e3ca659a31865f3d0718dfa3bc1eb1ec1ea1
+DIST trove_classifiers-2024.7.1.tar.gz 16060 BLAKE2B 4b662d9f440423167d4e715beebaa5993d83dfbab575e9c5b1a549b60f85abb9e10cec09c702d403e3655cafd002b9bf67c02808bbfac6746b2c395f8a0ce102 SHA512 c3092bce086f0530ca10326d2e99ea331e73b31fe47272835ff1a1042588dc616ccf8ce5e6eda5d48b5f199bc5c1a3206d4f17be62dbf751029e498c1231bd11
+DIST trove_classifiers-2024.7.2.tar.gz 16071 BLAKE2B 6f13df1498b68e2f24838473ad8b6feb341e33da6eabc2e104c823e6db65ada348ef36c8fd96226818d89c11bf0b0ac9665c9a6ecbea5ba620d2e48c64c5b82f SHA512 af9a366425e845b1bbd098c8085ec8064dbf6864940c7dd5def1672c2046756e2c76255b282b2c989c34d14b113b7c6abd32d23eeed88317d374043040f46486
EBUILD trove-classifiers-2024.5.22.ebuild 1122 BLAKE2B 9ea4a1a8a112202b1e7cb7617547ef09cf03310be09fede68836737b62ca76e5c5071a0a41f5318ade45e041de7d501782a48b2ebc3ac0e05a96d4ef40fed1c9 SHA512 6021b9830abfff461f6b9c34c6a422ead6bdedf909b17210cc03fe33eaae205a3ce41b7990b7f6241bbaa1a8428e47bec4c63ff87ea611e77d8f390d10429fc1
+EBUILD trove-classifiers-2024.7.1.ebuild 1130 BLAKE2B b160c4eebee65aeaf8596088057b844c622237db524535758d826cd17baa45a4860adf7ae39308f6774fffa695593889b6194073796517a7bf4e4b77d3aac92c SHA512 926d06d2d31dbe38d61c2b51a0512fde708782a5eb46630ba357ae5faf625d89b88c56a46699ae6077b4431768dbed9eb237d4bbe1b56a27dd439b9236df880c
+EBUILD trove-classifiers-2024.7.2.ebuild 1130 BLAKE2B b160c4eebee65aeaf8596088057b844c622237db524535758d826cd17baa45a4860adf7ae39308f6774fffa695593889b6194073796517a7bf4e4b77d3aac92c SHA512 926d06d2d31dbe38d61c2b51a0512fde708782a5eb46630ba357ae5faf625d89b88c56a46699ae6077b4431768dbed9eb237d4bbe1b56a27dd439b9236df880c
MISC metadata.xml 385 BLAKE2B 0d679ace6575dab100af9918e8b6dbde2f70cbf556c23ee667d68f69c6dd07887e43a513a73e60849a7a4b88cb26d4cd85b4cb905b926ee3832161c663adc9c0 SHA512 977bc86d4fb2dfcc887fd8d4038b8ac76cb0f4783424d3ab0857256afaf5dacf4e45c0d2a9166daa854be1dc8faba4a10c4718c557b983a1c7bb0a33fcd61f41
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.7.1.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.7.1.ebuild
new file mode 100644
index 000000000000..8fea4e4a1421
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.7.2.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.7.2.ebuild
new file mode 100644
index 000000000000..8fea4e4a1421
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.7.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}