summaryrefslogtreecommitdiff
path: root/dev-python/trove-classifiers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-20 00:15:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-20 00:15:26 +0000
commit1534d50aaf24272ec425fa439389ef7e1f7bf174 (patch)
treec48ca34f49e5c335c0d06b96d9f09d4a74e144d5 /dev-python/trove-classifiers
parent2e512e4e32285f8c4eb19586d014cb9d31454ec9 (diff)
gentoo auto-resync : 20:02:2025 - 00:15:26
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest2
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2025.2.18.16.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index cc5e3520a9d0..643b006355f8 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,3 +1,5 @@
DIST trove_classifiers-2025.1.15.22.tar.gz 16236 BLAKE2B 23003b48c5f6b919559c3355b9eda56d229c5e19420368200952ab9a81a6ca850c779788ccb3c9340bd08e11f9c1da6ea67ecc180c206216313064881d3469f8 SHA512 460df4327866ea6ef19ea04e9ea4dd746eb733ceafec0db9920b1e6eb1649abfcc914f4e103700072696846c4af4c85003a1ef6323b4605a8f1659126d459503
+DIST trove_classifiers-2025.2.18.16.tar.gz 16271 BLAKE2B 99f21fb5a6d40029cb53d2ce0b59c387b012e2538cfab8efb902bc8941499beb4b2ef506662442c5f2a0d2719099858e9bb4c9140514f41a4821436b7eefae30 SHA512 776082bbc7aac7fd4219fe9641261b439394b45ffb7b7f2e639e3f2fe583faa4594dc0113fd3ab3197035fa72c94ab378078023a6534721e640c01e9e5ce249d
EBUILD trove-classifiers-2025.1.15.22.ebuild 1137 BLAKE2B 0c4c4b614cee8999105bb573a538e15e0c4e481c6bcc65558d3f57bbc6809cbef1e33c2593cb8295bccf64ad89cd23f4db06fa4b70bc359721e6f513f9ccc0d3 SHA512 cc745422fa53f5a0914f02821a3c4d1a486d9e6e3fa6296e52e4f8989de6b421c2ea5a630e811ef47fd48017130de55792a9256b444eb134e4ce569a4aa366ac
+EBUILD trove-classifiers-2025.2.18.16.ebuild 1145 BLAKE2B 00a1585d83cc238ce00398036d504ff772137cc6bae2a899950ee98434e87670d4f8440646af343170e83eba1b8c42d09851dbb9c2a75d7d2c5c69df2be324b0 SHA512 667861b44479cc644034e18f7217fa0b5bd4676eda60cfc90a53c4a92689802dc385ffe64ba533f223392306992410493176e73fb13d43ed9ff4df6deaaa7adc
MISC metadata.xml 385 BLAKE2B 0d679ace6575dab100af9918e8b6dbde2f70cbf556c23ee667d68f69c6dd07887e43a513a73e60849a7a4b88cb26d4cd85b4cb905b926ee3832161c663adc9c0 SHA512 977bc86d4fb2dfcc887fd8d4038b8ac76cb0f4783424d3ab0857256afaf5dacf4e45c0d2a9166daa854be1dc8faba4a10c4718c557b983a1c7bb0a33fcd61f41
diff --git a/dev-python/trove-classifiers/trove-classifiers-2025.2.18.16.ebuild b/dev-python/trove-classifiers/trove-classifiers-2025.2.18.16.ebuild
new file mode 100644
index 000000000000..6c4761564980
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2025.2.18.16.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} python3_13t )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}