summaryrefslogtreecommitdiff
path: root/dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild')
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild b/dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild
new file mode 100644
index 000000000000..850f0b5ffda7
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2023.2.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+SRC_URI="
+ https://github.com/pypa/trove-classifiers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}