summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
commitf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (patch)
treedd0f7da0455831dffb2cb662e7dae760f92e68ad /dev-python/trio
parent770d63f36dbe1722e0ff9ab55eeca49986f01527 (diff)
gentoo auto-resync : 16:02:2025 - 00:13:18
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest2
-rw-r--r--dev-python/trio/trio-0.29.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 89b2417971c0..8d9e35e2e49c 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,3 +1,5 @@
DIST trio-0.28.0.gh.tar.gz 590844 BLAKE2B 4e9f89e0fd68db37bb07ee045809af8795216809885f79f6f247c7711be87995546f2db5a957f7ee5927edc60a442ed6d60a41cec7a559dd4acbc34d20435ba0 SHA512 2699cb55e237247737704852c34be6726746e35426c9a2ed3ca1a5e612a64fec0bd59e259bec4e88e1eb85c8d5a05e3f238346d8227ca0f9fcab271efe45bdd0
+DIST trio-0.29.0.gh.tar.gz 599433 BLAKE2B 35a162f01cca02134ffcd1c0cd3c072c1a20c07cc67038f3257fcb4732c696174ab3ee6e37706ffbb878b6a647d9e26489a55cdccb051b33c43517b660d227cd SHA512 88b6845c26f5bb02b749db7f64843e1858c3d52aad4332101022d61ec183f96304f1ce05a8ece5f97d04edf9aef668d791831439ae49fe1a7b904cf76061629e
EBUILD trio-0.28.0.ebuild 1750 BLAKE2B cf96452490c5db947418f7ac328a67fc6a3060a6dd42c905a2bd1eb5925cbe4b9724aa7380bd6203ee602ef2dd007b153f5af80c396fd291688843bf8f54c1b7 SHA512 09cb4fee22310846795f6b5e43d6d921033c7b9bfa714812b633f8a3ac7a780ec4fc067ad64654f9822349479967b29a0a8cbe93bbccc0ca0b9566b0b2608419
+EBUILD trio-0.29.0.ebuild 1757 BLAKE2B b239da2e0ef8640c61bd8b662e1b6197f69a8a7bb98686297bd02b1b892b0f5efe82f08196063d144cc57f00dfa62b1a9828cbf2594a98f9807ba2c4959f719c SHA512 c73c0a5743ebcd01795f23c59573f1c40d652472b5791d8ccecdf9e692a85186de4f715fe875d221ca7b7f3bd6f247b370c2cbd711c421af805001d3bd638fc7
MISC metadata.xml 2047 BLAKE2B 836ccc0a048706cf1770c695553403b855f54a42cb94a622b7f91583aaee72cffef27e567df2b7a74fdc7cec4c8574d2f16d00953923b4484f38013910f49dcf SHA512 5e482479d68272be879bfea06697d41109647880d6a72a7a3096f86aa029f54ae004c353f247041c8e517a01808eb929c3d666b0e85ef466fdca88bfb5b38cdd
diff --git a/dev-python/trio/trio-0.29.0.ebuild b/dev-python/trio/trio-0.29.0.ebuild
new file mode 100644
index 000000000000..3e7656159c38
--- /dev/null
+++ b/dev-python/trio/trio-0.29.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for async concurrency and I/O"
+HOMEPAGE="
+ https://github.com/python-trio/trio/
+ https://pypi.org/project/trio/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.2.1[${PYTHON_USEDEP}]
+ ' 3.10)
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.3.0[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# Bug https://bugs.gentoo.org/916756
+# distutils_enable_sphinx docs/source \
+# dev-python/immutables \
+# dev-python/sphinxcontrib-trio \
+# dev-python/sphinx-rtd-theme \
+# dev-python/towncrier
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+ # requires ruff
+ _tests/tools/test_gen_exports.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf trio || die
+ epytest -p trio._tests.pytest_plugin \
+ -m "not redistributors_should_skip" \
+ --pyargs trio \
+ --skip-optional-imports
+}