summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-17 18:49:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-17 18:49:32 +0000
commit5c94a4b3d11ad7b169e23bd604cf403c96bf4f1c (patch)
tree51700ddb4327326dcc3f915423b58b3842fef379 /dev-python/trio
parentd1ad4013179c639433bdbfa5025ca403aac0767b (diff)
gentoo auto-resync : 17:03:2024 - 18:49:32
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest2
-rw-r--r--dev-python/trio/trio-0.25.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index c30d17264925..f43223cd88e5 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,4 +1,6 @@
AUX trio-0.24.0-musl.patch 2793 BLAKE2B 2e15fa8703361e0bc55f1fa067e2f35e24a778f6e34ae0cc2c08a05c15bd385f70a5e5d485a5252caf5cdbae37223fd48bea035debb6140eda945257d6565278 SHA512 1cd8133ba0d7c80e7277c445f39329139abe8740905e43c531fd86b1a100d1e75bdf038c8f2189e3a310ed8692e826ab5745133ea70b638bc6ddc4f659b0a71c
DIST trio-0.24.0.gh.tar.gz 592652 BLAKE2B c102c6b6e25b497a5823b58b926f43d06905a8aaa41434d9503c127cb1b26a3c58594edc90e48e9acea6e6ffbc36a2d02a9f1805b14ba65a77ffedcbb8cf48f8 SHA512 3f52e770a19c45b5227ffd34e7ae4664ee739dbae81c09e1e4bf2bd3eddb414ff9ab32dd2b18d59e420a18660a2f7db7ad2cda9f725729dda7e99f7a89b66bbc
+DIST trio-0.25.0.gh.tar.gz 599079 BLAKE2B d0615111fba3981c89d72a6eff93e9f500854e94f7227f3f235d4effa4ab53b9a280278b62db90c4a9612028edc5c9892b56464c9ee5b7e3c8120086dfc64e56 SHA512 0690193c501e054b5c2d96ea208d6a49b9ac860dd63a58c4b5cec5b5f6f197fc5eae0e2fae99ef498d5d1513b189a75504905bd5cc6dc34ae791e3451655933a
EBUILD trio-0.24.0.ebuild 1835 BLAKE2B 47252081fe8446c918645f740ce8df83beb9368d1ffd43b124130ea8e4c68e5309c41c3062a5118c3129b10f43f9e99fc3c3d4b26cb71532b991163dfec58eba SHA512 d6a3f9c691f7d5df4fad53ed451a533b2fad670576e2f415ada22f716e29307e454ffc50aa8ea1fef47362c7196f6acdd9807c5cf9cb021194097c0f214aeb5d
+EBUILD trio-0.25.0.ebuild 1749 BLAKE2B f7704d67a41e99ba0dfc8a088e0046d9f2bd6cc0a8de64d021e345002009779da17f1a78220b2f61c36161969736146d43edc0b6fe7a3888f55c904382920425 SHA512 65fb7a2f926638bd094239603f3ea724a80ca8528f9ff0ff812101f8d06beb802e19804c44d06d6eb3fc646708b39ad6e81fc108372f1e84f312e6e40b81d017
MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/trio-0.25.0.ebuild b/dev-python/trio/trio-0.25.0.ebuild
new file mode 100644
index 000000000000..01f9924188d7
--- /dev/null
+++ b/dev-python/trio/trio-0.25.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for async concurrency and I/O"
+HOMEPAGE="
+ https://github.com/python-trio/trio/
+ https://pypi.org/project/trio/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ ' 3.10)
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.3.0[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# Bug https://bugs.gentoo.org/916756
+# distutils_enable_sphinx docs/source \
+# dev-python/immutables \
+# dev-python/sphinxcontrib-trio \
+# dev-python/sphinx-rtd-theme \
+# dev-python/towncrier
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+ # requires ruff
+ _tests/tools/test_gen_exports.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf trio || die
+ epytest -p trio._tests.pytest_plugin \
+ -m "not redistributors_should_skip" \
+ --pyargs trio \
+ --skip-optional-imports
+}