summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 00:25:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 00:25:50 +0000
commit48dbe17904ac8ee6f006488d8f21734b0d253db4 (patch)
tree90c7f087cbefd4ac6b893072d309e75dbf019f76 /dev-python/trio
parent7972abc05090180dcc09d2b16af4020ce1cd1841 (diff)
gentoo auto-resync : 17:03:2023 - 00:25:50
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest2
-rw-r--r--dev-python/trio/trio-0.21.0.ebuild66
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 02ff27f36f90..007bba1d77e7 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,5 +1,3 @@
-DIST trio-0.21.0.gh.tar.gz 491228 BLAKE2B e5f65d3aa9e4bc0c449e3986048d63fe3001a2eee96dbe5d8c088e0fce786b1d50861b47170baa7cced097938b16c92f0efd51518404a5e0ea6a17a48d656823 SHA512 383b11f264ddf4c78eb75829472826ebacf32d063790e8d4681d5df2f21c4f9287884db1752fd19976b674643adf7299816d4404e3032193ef90f522ad9cfa79
DIST trio-0.22.0.gh.tar.gz 517482 BLAKE2B ab1fcb22d8f0ed9c8de831a9384b55ab433811863974cb767cb0ea4eb3a0df7372b5ea2c2d4c2af3ca1d3c8c3144d5546ad8cc68276b17ecb3d20ea1858ba9e0 SHA512 45b813d6cc65f8d49f70cb0ea7f33593fed0cc5989c60ba449f0b38c4759604aa7360cd016758fd364438b92516be549edf1efd583c7f5ee2de8813334f182bc
-EBUILD trio-0.21.0.ebuild 1724 BLAKE2B 424c9bd646a3642c606fd3062a08141e785e7dc38baeee1e244479b9625ba5e18ddb0abe524262562476bea2251dcd2936221f2ed5b0c9de80e665c7b1d5b2ca SHA512 b08ce45659128853a3012ccdbb5070b133c96aa185de2b7df326c1d93551e1df4d6fecbdd410c3decd3cc33799f109c9c390f947072b399bc7c4398c61028b68
EBUILD trio-0.22.0-r1.ebuild 1981 BLAKE2B 2e5162f1bdfc90f7cca02210e461d99fde2c74e371f6002d2170f1ac13e6d399a4029ca486c5600e046f8d250ffb230b2075054780c33b87ffc41e988c33ac2b SHA512 a9e5e9a5f9b7bbe176eb369c296e8ec446f3addb53701f8f3c3d06463ee2a939a6c0434c0774ace874b054185baf6286f30d53bc90630d534f5ac74a42a59ada
MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/trio-0.21.0.ebuild b/dev-python/trio/trio-0.21.0.ebuild
deleted file mode 100644
index f4e3f619a5ec..000000000000
--- a/dev-python/trio/trio-0.21.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for async concurrency and I/O"
-HOMEPAGE="
- https://github.com/python-trio/trio/
- https://pypi.org/project/trio/
-"
-SRC_URI="
- https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="|| ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- dev-python/sniffio[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-# NB: we're ignoring tests that require trustme+pyopenssl
-BDEPEND="
- test? (
- >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source \
- dev-python/immutables \
- dev-python/sphinxcontrib-trio \
- dev-python/sphinx-rtd-theme \
- dev-python/towncrier
-
-python_test() {
- local EPYTEST_IGNORE=(
- # these tests require internet access
- trio/tests/test_ssl.py
- trio/tests/test_highlevel_ssl_helpers.py
- )
-
- local EPYTEST_DESELECT=(
- # Times out on slower arches (ia64 in this case)
- # https://github.com/python-trio/trio/issues/1753
- trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
-
- # incompatible ipython version?
- trio/_core/tests/test_multierror.py::test_ipython_exc_handler
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m "not redistributors_should_skip"
-}