summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/trio
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest5
-rw-r--r--dev-python/trio/files/trio-0.20.0-py311.patch26
-rw-r--r--dev-python/trio/trio-0.20.0.ebuild37
-rw-r--r--dev-python/trio/trio-0.21.0.ebuild66
4 files changed, 119 insertions, 15 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index 36f364bac934..0a6b7c0a4301 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,3 +1,6 @@
+AUX trio-0.20.0-py311.patch 957 BLAKE2B 0f8bdb92644a5bba2ad4f00a03920fd67f421ac07617f0e830a471608bb5b141d32f545d17847bb7b4f8aa5fb08444be45e32b1306561956ca585b8c1b449e7f SHA512 07e2ddd315bfc449e14dad2b67a4735c625a4c765abf4fadaa8dd4b904b723613831e7c65cbb7aea7e3bda5a5558e3951e8eb2d86398754ddea7844ed857de7e
DIST trio-0.20.0.tar.gz 491254 BLAKE2B 354e8019d1ba8ac35bbb00477806ab87d62de0e9a94b1ff3a4d63c024af8cd40261c46a2c9449f38550e809938f3c6ee620a47e866bc31203c3c4a4984446fa5 SHA512 9aa431d0bc28737dd48a7358446acaffbf34860dc467ac121166f7241ebf4a4ed8bcdc8dc0277034e3c3fd70f1f8a57d790e98bdda7a1141f2c53c6b85a97a3c
-EBUILD trio-0.20.0.ebuild 1715 BLAKE2B 330a9bd53d97975c99231b42e3fcf26ffa0ed5dbc7bc00a097077ae7712214288c7af0a044c8ea63f079e6017e6ec6625cbbfadb3078dfb8392b1b9b959fef4c SHA512 f479abf2433d86c62ae5e0693a2a522117f656e547d3319422cce729d132740a0f3fdd3b14038c24c4e44177854a57d89f79125a275e253fdd4a2bb3d5842f76
+DIST trio-0.21.0.gh.tar.gz 491228 BLAKE2B e5f65d3aa9e4bc0c449e3986048d63fe3001a2eee96dbe5d8c088e0fce786b1d50861b47170baa7cced097938b16c92f0efd51518404a5e0ea6a17a48d656823 SHA512 383b11f264ddf4c78eb75829472826ebacf32d063790e8d4681d5df2f21c4f9287884db1752fd19976b674643adf7299816d4404e3032193ef90f522ad9cfa79
+EBUILD trio-0.20.0.ebuild 1955 BLAKE2B 0cca3b4b1ce120da3704f831316db9027d507557825b05e15d171d2e20061dbd9dfdf96a26d2ee16e1513ac4040f5973d626e6616781622273ed1b849428eb27 SHA512 c7b612dc393ca7887835b22549f93cc981bfa4e7779b153ea04989766b2bf1fd3e4d1c3761382233d4fa67d36a50da9079300e3c36802f367cab310cb12ceeaf
+EBUILD trio-0.21.0.ebuild 1750 BLAKE2B c4cd4732d186f2731695cd8788719ab366b7bb3ca8cba0a4098392fe2f354c74091d064ee46b70907ec9cfab61d3e369e333df1ba934e34f6d6fd8e8c84df39a SHA512 2e57a8f7c0d1aa15b0462bbbc0778569212e3f532173f8a9918052b9176da9d51de5e115b5f6ef514e7eb26cae54bf67eeaf2c8353cd4d4ee6c4a12be0e2a4f7
MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/files/trio-0.20.0-py311.patch b/dev-python/trio/files/trio-0.20.0-py311.patch
new file mode 100644
index 000000000000..f7d447825a16
--- /dev/null
+++ b/dev-python/trio/files/trio-0.20.0-py311.patch
@@ -0,0 +1,26 @@
+diff --git a/trio/_core/_multierror.py b/trio/_core/_multierror.py
+index 6dfdaa7a5..de0d56d46 100644
+--- a/trio/_core/_multierror.py
++++ b/trio/_core/_multierror.py
+@@ -383,11 +383,10 @@ def traceback_exception_init(
+ capture_locals=False,
+ compact=False,
+ _seen=None,
++ **kwargs,
+ ):
+ if sys.version_info >= (3, 10):
+- kwargs = {"compact": compact}
+- else:
+- kwargs = {}
++ kwargs["compact"] = compact
+
+ # Capture the original exception and its cause and context as TracebackExceptions
+ traceback_exception_original_init(
+@@ -421,6 +420,7 @@ def traceback_exception_init(
+ # copy the set of _seen exceptions so that duplicates
+ # shared between sub-exceptions are not omitted
+ _seen=None if seen_was_none else set(_seen),
++ **kwargs,
+ )
+ )
+ self.embedded = embedded
diff --git a/dev-python/trio/trio-0.20.0.ebuild b/dev-python/trio/trio-0.20.0.ebuild
index 721a7b11a297..10ace0d68090 100644
--- a/dev-python/trio/trio-0.20.0.ebuild
+++ b/dev-python/trio/trio-0.20.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -38,19 +38,8 @@ BDEPEND="
)
"
-EPYTEST_DESELECT=(
- # Times out on slower arches (ia64 in this case)
- # https://github.com/python-trio/trio/issues/1753
- trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
-
- # incompatible ipython version?
- trio/_core/tests/test_multierror.py::test_ipython_exc_handler
-)
-
-EPYTEST_IGNORE=(
- # these tests require internet access
- trio/tests/test_ssl.py
- trio/tests/test_highlevel_ssl_helpers.py
+PATCHES=(
+ "${FILESDIR}/${P}-py311.patch"
)
distutils_enable_tests pytest
@@ -61,6 +50,26 @@ distutils_enable_sphinx docs/source \
dev-python/towncrier
python_test() {
+ local EPYTEST_IGNORE=(
+ # these tests require internet access
+ trio/tests/test_ssl.py
+ trio/tests/test_highlevel_ssl_helpers.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+
+ # incompatible ipython version?
+ trio/_core/tests/test_multierror.py::test_ipython_exc_handler
+ )
+
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # test for functionality that has been removed from py3.11
+ trio/tests/test_util.py::test_coroutine_or_error
+ )
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -m "not redistributors_should_skip"
}
diff --git a/dev-python/trio/trio-0.21.0.ebuild b/dev-python/trio/trio-0.21.0.ebuild
new file mode 100644
index 000000000000..6fc1ee37808f
--- /dev/null
+++ b/dev-python/trio/trio-0.21.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for async concurrency and I/O"
+HOMEPAGE="
+ https://github.com/python-trio/trio/
+ https://pypi.org/project/trio/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+# NB: we're ignoring tests that require trustme+pyopenssl
+BDEPEND="
+ test? (
+ >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/immutables \
+ dev-python/sphinxcontrib-trio \
+ dev-python/sphinx_rtd_theme \
+ dev-python/towncrier
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these tests require internet access
+ trio/tests/test_ssl.py
+ trio/tests/test_highlevel_ssl_helpers.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+
+ # incompatible ipython version?
+ trio/_core/tests/test_multierror.py::test_ipython_exc_handler
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not redistributors_should_skip"
+}