summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/trio
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest4
-rw-r--r--dev-python/trio/metadata.xml4
-rw-r--r--dev-python/trio/trio-0.20.0.ebuild34
3 files changed, 25 insertions, 17 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index e63a9e2b7444..1fea7a80a174 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,3 +1,3 @@
DIST trio-0.20.0.tar.gz 491254 BLAKE2B 354e8019d1ba8ac35bbb00477806ab87d62de0e9a94b1ff3a4d63c024af8cd40261c46a2c9449f38550e809938f3c6ee620a47e866bc31203c3c4a4984446fa5 SHA512 9aa431d0bc28737dd48a7358446acaffbf34860dc467ac121166f7241ebf4a4ed8bcdc8dc0277034e3c3fd70f1f8a57d790e98bdda7a1141f2c53c6b85a97a3c
-EBUILD trio-0.20.0.ebuild 1848 BLAKE2B f243d34756433855c9964a4978e2956894a1ea5e3dbe1a67b9a52af6ee1295c54111ec86b1508ec03dc83d505ca2fd6dead72791b50489544a5fd549d920b969 SHA512 8cc77add9c6335bc4e3cad922c8e0452ef5e38565bd73800bf8de3e1707f78a8a0d31bd53060bb418c7659d68a25b49346f109357db93345d467539290061502
-MISC metadata.xml 1959 BLAKE2B 8b8c53b057e11c334de01db932a4b7cb9dba98c200142765224af1252be7e3e756ebd2e8c1295212d8930df2afecafdaf252375e3e842c58d8149432ed038606 SHA512 d7ad911af38df2e7ef4e0659b3a8abf25c334e10d0a637c1d901a05e517e5caeee68932e4263c1bdedbee6af6e15b80cb1bb377ababe4078a507fc5096073b1a
+EBUILD trio-0.20.0.ebuild 1689 BLAKE2B 23599822ed09d9aa35d4e685edb8aa4d1b40bc437bf3a3a0fd9704c4c01ffc608600528dbaabb0ed3dfdbc1f961d0e3a066a45f54133c75912c37717e012d70f SHA512 bb63203f33ba168fb79088ae2feec503a5ec5a4271761e1313d136ac1844f75b0e780e43ed802e86a3410591eb1a89e6a78073ac52d55687afe0e7a379d8e6ee
+MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/metadata.xml b/dev-python/trio/metadata.xml
index 3cfd749824db..9a0a7c3b54c5 100644
--- a/dev-python/trio/metadata.xml
+++ b/dev-python/trio/metadata.xml
@@ -6,6 +6,10 @@
<email>andrewammerlaan@gentoo.org</email>
<name>Andrew Ammerlaan</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<stabilize-allarches/>
<longdescription lang="en">
The Trio project's goal is to produce a production-quality, permissively licensed, async/await-native I/O library for Python. Like all async libraries, its main purpose is to help you write programs that do multiple things at the same time with parallelized I/O. A web spider that wants to fetch lots of pages in parallel, a web server that needs to juggle lots of downloads and websocket connections at the same time, a process supervisor monitoring multiple subprocesses... that sort of thing. Compared to other libraries, Trio attempts to distinguish itself with an obsessive focus on usability and correctness. Concurrency is complicated; we try to make it easy to get things right.
diff --git a/dev-python/trio/trio-0.20.0.ebuild b/dev-python/trio/trio-0.20.0.ebuild
index 5611597d176c..a544993a08dc 100644
--- a/dev-python/trio/trio-0.20.0.ebuild
+++ b/dev-python/trio/trio-0.20.0.ebuild
@@ -3,16 +3,20 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1
DESCRIPTION="Python library for async concurrency and I/O"
HOMEPAGE="
- https://github.com/python-trio/trio
- https://pypi.org/project/trio
+ https://github.com/python-trio/trio/
+ https://pypi.org/project/trio/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
"
-SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="|| ( Apache-2.0 MIT )"
SLOT="0"
@@ -31,9 +35,6 @@ BDEPEND="
test? (
>=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
>=dev-python/immutables-0.6[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- >=dev-python/jedi-0.18.0[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
)
"
@@ -42,10 +43,8 @@ EPYTEST_DESELECT=(
# https://github.com/python-trio/trio/issues/1753
trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
- # Fail with Python 3.10 on 'IPPROTO_MPTCP'
- # Everything else passes and this is a simple check for exported symbols
- # Let's try again with the next release (after 0.19.0).
- trio/tests/test_exports.py::test_static_tool_sees_all_symbols
+ # incompatible ipython version?
+ trio/_core/tests/test_multierror.py::test_ipython_exc_handler
)
EPYTEST_IGNORE=(
@@ -56,7 +55,12 @@ EPYTEST_IGNORE=(
distutils_enable_tests pytest
distutils_enable_sphinx docs/source \
- dev-python/immutables \
- dev-python/sphinxcontrib-trio \
- dev-python/sphinx_rtd_theme \
- dev-python/towncrier
+ dev-python/immutables \
+ dev-python/sphinxcontrib-trio \
+ dev-python/sphinx_rtd_theme \
+ dev-python/towncrier
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not redistributors_should_skip"
+}