summaryrefslogtreecommitdiff
path: root/dev-python/trio/trio-0.19.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/trio/trio-0.19.0.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/trio/trio-0.19.0.ebuild')
-rw-r--r--dev-python/trio/trio-0.19.0.ebuild36
1 files changed, 24 insertions, 12 deletions
diff --git a/dev-python/trio/trio-0.19.0.ebuild b/dev-python/trio/trio-0.19.0.ebuild
index 9cc46ddc68a3..b02ca40ed6e5 100644
--- a/dev-python/trio/trio-0.19.0.ebuild
+++ b/dev-python/trio/trio-0.19.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -16,7 +16,7 @@ SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.
LICENSE="|| ( Apache-2.0 MIT )"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv sparc x86"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
RDEPEND="
>=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
@@ -26,29 +26,41 @@ RDEPEND="
dev-python/sniffio[${PYTHON_USEDEP}]
dev-python/sortedcontainers[${PYTHON_USEDEP}]
"
+# NB: we're ignoring tests that require trustme+pyopenssl
BDEPEND="
test? (
>=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
>=dev-python/immutables-0.6[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
>=dev-python/jedi-0.18.0[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/pylint[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-python3.10.patch
+)
+
+EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+
+ # Fail with Python 3.10 on 'IPPROTO_MPTCP'
+ # Everything else passes and this is a simple check for exported symbols
+ # Let's try again with the next release (after 0.19.0).
+ trio/tests/test_exports.py::test_static_tool_sees_all_symbols
+)
+
+EPYTEST_IGNORE=(
+ # these tests require internet access
+ trio/tests/test_ssl.py
+ trio/tests/test_highlevel_ssl_helpers.py
+)
+
distutils_enable_tests --install pytest
distutils_enable_sphinx docs/source \
dev-python/immutables \
dev-python/sphinxcontrib-trio \
dev-python/sphinx_rtd_theme \
dev-python/towncrier
-
-python_prepare_all() {
- # these tests require internet access
- rm trio/tests/test_ssl.py || die
- rm trio/tests/test_highlevel_ssl_helpers.py || die
-
- distutils-r1_python_prepare_all
-}