summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
commitfa77846c708f4d0541b610846a5f2ed14b4b20c1 (patch)
tree35860ca9d75749380daddffe86bbd70d3c5866a9 /dev-python/trimesh
parent640c4638f1e12a2c71f539ee18564a0c82d19947 (diff)
gentoo auto-resync : 07:08:2023 - 09:24:28
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-3.23.1.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index eafcc6639e34..8b8473084ad9 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-3.22.5.gh.tar.gz 12715459 BLAKE2B d838b75acef1615fab5006cd55cd28d649fd61fbecbe076250d3f2acd6d0c6f29481862189105456e9626b15b1f6e557f419cbe49044ccff784d9ea2a8ea4dff SHA512 1756f8a589cff214ef6ecf54f363c906b26a1d7205aa1645cb5f90b691d6c43d71f904939329b599c0b5595b663529b15c4d8a747da50157a22e3020808f3f01
DIST trimesh-3.23.0.gh.tar.gz 12720387 BLAKE2B 88e57f09c1bc924a59b6ce3744ef3e3df05d144707415fe595f40d411e364591cdd22ed38a46b2004d935ab18f3387753cf66479aaeb9cc1f4d870c1e23ce7e3 SHA512 d4ac6b5c7ea09c84810a36060c6cb9a5366ef177d309d1d0bf2cfbdd0969562394ee03832f9a535d63cb71b5c026fb6bf43b815014230c8e20c56bb69f0fc3ed
+DIST trimesh-3.23.1.gh.tar.gz 12721718 BLAKE2B e6f388c0b3443b46bb6a4e93b049b4a75c5c7af7e24c441f1b0c5c4247ac34d3548722ea24979897c332b4defb69681e5bf714848dd6e3d89af18b2a0adc7e18 SHA512 2a788631f7bb142da5f761ed374c1966b92799a4e4ce52687bf86ee7da3d226466771a84876eaf8fb71b5fc967d69fbce286c4638e0f14a9c8d3e80094079283
EBUILD trimesh-3.22.5.ebuild 1888 BLAKE2B 8c7e4b95a97b3d522089f2d75d53c97243ac18175231cd41edae7cc948a3685223c61a4d43d76b182962ed0184e912e2796f6b70e98e79e1c4fc5139b7806afc SHA512 f60002a7775837ea1e6800f2c3a3a2b1124e33258a62683f19f13197bc1ddca16853e993e65ae965a652c53648a5e678e33c2594cb69c21f50158dbdbfbef28b
EBUILD trimesh-3.23.0.ebuild 1889 BLAKE2B 3b329b14222f1ca0f70cfc138c44c01e6eb9826e76f6805ce7e42a40b177d5e7514d03c8c45375cdd91c1aceca305137cac9b7c6a6c86ad51be9ca5db29967e8 SHA512 a84336ae1aede43effa0a4a44b41ba399703361a05081b44a352f189d7f5a9c219f73e7229eebf4678729b4e5f88a1c940b217adc2748140e1709526e44619c7
+EBUILD trimesh-3.23.1.ebuild 1889 BLAKE2B 3b329b14222f1ca0f70cfc138c44c01e6eb9826e76f6805ce7e42a40b177d5e7514d03c8c45375cdd91c1aceca305137cac9b7c6a6c86ad51be9ca5db29967e8 SHA512 a84336ae1aede43effa0a4a44b41ba399703361a05081b44a352f189d7f5a9c219f73e7229eebf4678729b4e5f88a1c940b217adc2748140e1709526e44619c7
MISC metadata.xml 495 BLAKE2B b8b403f7bfbac53ed234c2ba50324041502a28465d70e9406867f05741e0313845307491fcfd85f05e2993b21daf14117a4b6863b45422fd4c62c6e28902e3ff SHA512 3deec8ab4b513536a7fe182be8f1b96e06fd06b2480d3e516c2b3462cc26fcbdeb1d165b4d0297465e93c0cce584ab40a8f905b81a59dcb4040a39655028783d
diff --git a/dev-python/trimesh/trimesh-3.23.1.ebuild b/dev-python/trimesh/trimesh-3.23.1.ebuild
new file mode 100644
index 000000000000..c7b61d98e83f
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.23.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)" --dist=worksteal
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}