summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-24 04:04:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-24 04:04:24 +0100
commite7daa1f959ba2c720f36a6984f588098e68b15cd (patch)
tree42ed099f2514ebda2681a4de13af60727c8a9fab /dev-python/trimesh
parentfd93fe10d9e6c855fed8e1524b2d2d64d2085570 (diff)
gentoo auto-resync : 24:10:2024 - 04:04:24
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-4.5.1.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index dba2906a7f81..dbf9c80a72e5 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-4.4.9.gh.tar.gz 13612220 BLAKE2B 9ee21f8a3f0db041133b2843948a00e8ee6bf52e3de1d2ca9ac88391ef1c07a4b540c75b439da3e137923f0822399cdf759072729363253ad8137a06cb208791 SHA512 3b58a0378231dd1111ac4ffe030b1dd18d24647e22fe815bc411a7854f83e12a9482cb0b48d5333be9f6f6ebf622c15e29c446531ce27ff12c1835a6f25cc51a
DIST trimesh-4.5.0.gh.tar.gz 13615659 BLAKE2B 4355e3577084f0b2fbb60efd09e4278c839a76e7e0980528d2b0456f7d72c1a2764ecdc3b5f6969489d280f81a8dd5bfd04c758c4682b816774ce13289ccc8a3 SHA512 a3402e736698dc8b6a78a94742d8256874d7f7f9fecd4e8cdf045f50aea452dfa8e960e3d1d9c773db87eb39b226c41d4ffefbf67f5ab93f85ccf98062a8df54
+DIST trimesh-4.5.1.gh.tar.gz 13615930 BLAKE2B c3477dba45e27e50e9dd295693abd3c5f87aefefaa8b9f68efae3e36a7fd8b2fa74f319535dd3a5b9cf795c5603f11e1bc1ca78e7ad98b78c46b9349c7be91f9 SHA512 5cd289dce9f6913afc9708de16bec2f0fb2f5c1d171f9c043bb3f2a0ac56d59a06e0c4e4bfaf833594850abbb75ab798331bbad28f9089998f801979cabe3657
EBUILD trimesh-4.4.9.ebuild 2034 BLAKE2B 28b0063eefd036c6d882d0907b04eed1abacaf1206be8677b9e72c5e0d479bacbce43150227383ac9d2163b65f6dc405456e7064642f34f3c3d9b93e17964935 SHA512 624b55d78b99eddaf8e3446cf07d04344fe83c1f4b3033b75c076841f721e2bdc798e8b5e8cfddbc01db1d9e36f7232f5ff9145325c5e82bd5faea34b417ddfe
EBUILD trimesh-4.5.0.ebuild 2139 BLAKE2B 2b95f1452a1f9b007bb085b0abca7f171d7fdeba6c7c666de89cdd734f02b232551bd66c990adbac7a7fb5e17daba3feff5436d4abbe29c4303754d207b4f7d3 SHA512 170771013ace7431e0e573f97ff72cc11da9ecdac86ebdee7204e19fc4aa6aed40147d4c4ccea7aa1bc73b9d0c75855fcbf5d5a1fc90646af30676ac9081f104
+EBUILD trimesh-4.5.1.ebuild 2139 BLAKE2B 2b95f1452a1f9b007bb085b0abca7f171d7fdeba6c7c666de89cdd734f02b232551bd66c990adbac7a7fb5e17daba3feff5436d4abbe29c4303754d207b4f7d3 SHA512 170771013ace7431e0e573f97ff72cc11da9ecdac86ebdee7204e19fc4aa6aed40147d4c4ccea7aa1bc73b9d0c75855fcbf5d5a1fc90646af30676ac9081f104
MISC metadata.xml 389 BLAKE2B 6dcc92dfafdedb5cc7fe5f40977594114bbf1628d8179d7222c3b60c4a591e236c7a937530006beb9649a8a84636bcb1923d8ad6a377994295f85b1fe8eb8bbd SHA512 a96f4fb6a1c2bd820f2dd072230fa160536834e1ef19483c372571df2d082cb5a63434181af9107022b75e1019d369d6bece8262eb752cedf24a5038e15ea473
diff --git a/dev-python/trimesh/trimesh-4.5.1.ebuild b/dev-python/trimesh/trimesh-4.5.1.ebuild
new file mode 100644
index 000000000000..7b71b21dd4d0
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.5.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ dev-python/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox-earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires manifold3d
+ tests/test_boolean.py::test_multiple_difference
+ )
+ local EPYTEST_IGNORE=(
+ # require pyinstrument
+ tests/test_sweep.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}