summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 14:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 14:01:09 +0000
commitdfa2037f41649c9775d690a3d01cfd5cabf4db71 (patch)
tree261884874fd25b6a9bff06b2e5f6106d091e3848 /dev-python/trimesh
parent8ba94db1fe69019bb2d3b4f50fe9d1ccf3d94b3a (diff)
gentoo auto-resync : 15:02:2023 - 14:01:08
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-3.20.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index a7f09b57b927..c0e30d35be54 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-3.18.1.gh.tar.gz 12657109 BLAKE2B 8e5370193e7d47f1dc2d7d43c356df1a56c2b4b8af6f47ac6aa889b04a3b950ec507b5cc0fe6f99f874cf66111aa72773025ba3821013466bb34baced3a361ca SHA512 72936c0fc6f89ffa35b80928dc5abac8ca4fac023f5be1d4adec6d020f3da6ee2c7a97efb0cecf58faad94ef6f33949533ac789affcecee07696ca0188fd47f0
DIST trimesh-3.19.4.gh.tar.gz 12673418 BLAKE2B c54e0e1a946b858371d5de2f028bbc64a353a06859f428d6e221058a46e853bb7f245d7348b1cc7fbbdb930ba9600e24a39c2884a9acfa00b9d31d6576b87959 SHA512 b490e6d021a41c0a094c5e3596033a189d08310c04a2ce70c9b72d492e1cad1b5c9f110487c66d0a37eed97754e979c7b449d10a6a6abdbd81241099c248d5cf
+DIST trimesh-3.20.0.gh.tar.gz 12678960 BLAKE2B f99ff3d7fd1a84e1ce9b6d1d67b38216aa8b3e3250096f2ac7c4585fffe0a4e565c093bf30bd98bf46daa910c80266edd12dbd43c5a2aef8a7d66c75b08972cb SHA512 82eb81d8b43880d1205c31ddcc085735cfc0bf64eb4918fd539fe5b476c107f484ff1b969d6f8bdb0ac2486d201ba1ff4316b84311afc38853ffbe8f13d0fb9b
EBUILD trimesh-3.18.1.ebuild 2217 BLAKE2B c230c692f86f17a22476b07c9f53932898002623f262883eaea2bb0fc6eadbf8a13df593aff9fb10081aaed92c6140c70608d92688cd4848b868611d69c6f936 SHA512 720f8b517b3ee4339d66f1e47c787b34fa52036673a458de0ca71ceb5a02dae0f3fe46c3e859d3864891becd88fc7dec69b7e8bd58044737bdef5646ed5832b2
EBUILD trimesh-3.19.4.ebuild 1909 BLAKE2B 41a362d9e7b0b9b69c90846fb7fdaafb8dc2486d74756fdfb96bc144072b46c12fb8fa60793b8bd2260532ea3f180e204ec4e24f84e566e58aaa4df62423f81d SHA512 8baf31739ecdf2a8f173bf001ad2ae40092995f0f5e0c5cc3ccf1b7aca724dc8b16b3a71308edf6121a66a7f6b1fe88ee47278446aa9b94c847a20167b0c0140
+EBUILD trimesh-3.20.0.ebuild 1909 BLAKE2B 41a362d9e7b0b9b69c90846fb7fdaafb8dc2486d74756fdfb96bc144072b46c12fb8fa60793b8bd2260532ea3f180e204ec4e24f84e566e58aaa4df62423f81d SHA512 8baf31739ecdf2a8f173bf001ad2ae40092995f0f5e0c5cc3ccf1b7aca724dc8b16b3a71308edf6121a66a7f6b1fe88ee47278446aa9b94c847a20167b0c0140
MISC metadata.xml 495 BLAKE2B b8b403f7bfbac53ed234c2ba50324041502a28465d70e9406867f05741e0313845307491fcfd85f05e2993b21daf14117a4b6863b45422fd4c62c6e28902e3ff SHA512 3deec8ab4b513536a7fe182be8f1b96e06fd06b2480d3e516c2b3462cc26fcbdeb1d165b4d0297465e93c0cce584ab40a8f905b81a59dcb4040a39655028783d
diff --git a/dev-python/trimesh/trimesh-3.20.0.ebuild b/dev-python/trimesh/trimesh-3.20.0.ebuild
new file mode 100644
index 000000000000..be6475bba950
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.20.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}