summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-25 08:44:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-25 08:44:28 +0100
commit6d57946e8f20a2294b96eca2e379d3e8e1c93384 (patch)
tree499ffd0e5fb14b9d907fa0d8bb11de0b757c6950 /dev-python/trimesh
parent237ad05f4a374a9f1707c3413a5094a6ce93e7ab (diff)
gentoo auto-resync : 25:10:2023 - 08:44:27
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-4.0.1.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 48b690ef26b1..8fe0813ec0b0 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-3.23.5.gh.tar.gz 12720153 BLAKE2B ef37eed712eb121529bf6bc724f96456a4dc86c7265b19d77a1bf578d2b5ffae043b5c3e0a03ad5be680125fcfced65ef933037defdc582e81d52b13ac11e9a9 SHA512 52783fe1c275aa121f412d5e2846d0d985e242a33e9c446e8bef538a53ba93b1f2e133e33e4f26390e1146ad8415c28fb146b2c74524c2aa20426819b1b875a0
DIST trimesh-4.0.0.gh.tar.gz 12921048 BLAKE2B 7592ba10b57aa5cafd47311a430f881cc1ecc917f503e0cea75b38d350738d35c937e1006f80a0acc8a54a33e55f41af3d6cf280751b82a932bd2428af12e033 SHA512 1f5c1a3e92d6bda2ed37e5c6ece9fde798a2c2766c816cbb6a8bf9fdbf489f733ea3988429107eb92043f723bc222348ffe9286663a03562834ae83391793257
+DIST trimesh-4.0.1.gh.tar.gz 12922631 BLAKE2B 81cad4efea89c308f9cbb749b2515ed51f9fc87bbd37505ab94c08698f257c7f3a1b04e1b4a919bf529ee47d7531ecd605dd613c68b13fdaf853161811dfd1e6 SHA512 bfe56b3cfc94fcaa066b953e6df4c70da6fe9a99a6230d7201196a7df897a386c3425ad1da3cc7df75fa0d888fd05d07bf14e6b579a04dddab813c3858f904ef
EBUILD trimesh-3.23.5.ebuild 1889 BLAKE2B 73f02af18e74968c85860076a52e529f7d18040797c18191cfc9b35c9fd7159ea11968f597a8ced58d735a499d675a85c6ad7e46f02474012bedb87bd2dab853 SHA512 fe9828489a68e74643fb3637a699e7083f71c75830773e0ab142147143923605c47edf0f4b8e68c36717e512a6c51c0dfc970136de30de04c1b740ddca59929c
EBUILD trimesh-4.0.0.ebuild 1890 BLAKE2B 128238b0c61aea055b0bb1fe15c552bcc3144c92effc64b0ba83b7a63c8acad1a6d7e719e21ac002d7d83665e28a083f17df0ce0366b929203ebd7b77e49e1fd SHA512 45d3cc8eca623afed3cc61fa1a72582a83060c5168085ac0303c8e6afbb4b7a9b0f363a2dd8e1f57ef23b39d8f762207a21a62968eb4a53bc5c2b4392dda68cd
+EBUILD trimesh-4.0.1.ebuild 1890 BLAKE2B 128238b0c61aea055b0bb1fe15c552bcc3144c92effc64b0ba83b7a63c8acad1a6d7e719e21ac002d7d83665e28a083f17df0ce0366b929203ebd7b77e49e1fd SHA512 45d3cc8eca623afed3cc61fa1a72582a83060c5168085ac0303c8e6afbb4b7a9b0f363a2dd8e1f57ef23b39d8f762207a21a62968eb4a53bc5c2b4392dda68cd
MISC metadata.xml 495 BLAKE2B b8b403f7bfbac53ed234c2ba50324041502a28465d70e9406867f05741e0313845307491fcfd85f05e2993b21daf14117a4b6863b45422fd4c62c6e28902e3ff SHA512 3deec8ab4b513536a7fe182be8f1b96e06fd06b2480d3e516c2b3462cc26fcbdeb1d165b4d0297465e93c0cce584ab40a8f905b81a59dcb4040a39655028783d
diff --git a/dev-python/trimesh/trimesh-4.0.1.ebuild b/dev-python/trimesh/trimesh-4.0.1.ebuild
new file mode 100644
index 000000000000..06f82a59ea08
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.0.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)" --dist=worksteal
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}