summaryrefslogtreecommitdiff
path: root/dev-python/translate-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-06 04:27:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-06 04:27:04 +0100
commitd6106fb0c1ab8f79024ab6a9ac2062ddc85d4e07 (patch)
treef3a4ad4dcf443e9351fa5dec88afeeec86c9b642 /dev-python/translate-toolkit
parentf3f72d0d5f1ae9ee74acaa63ccb7a247468e73bf (diff)
gentoo auto-resync : 06:10:2024 - 04:27:04
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.13.5.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 944075609220..2601ab08d4e1 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,5 +1,7 @@
DIST translate-3.13.3.gh.tar.gz 1172858 BLAKE2B e7b2f711faec3876fdc082aae02716beaa45934f2ad308433c20020e69b72850e0a9d32c7cb57e32b4fdc8b39334a358b8f289c83744882728616122f07cf8f7 SHA512 f435306b34a2a200df5b648a1354444ac5fd76872f36062704b2c8abf52b8b1e1d570afbcf4b50cb1d815abfcf85b05630e8bc02f908a83f3fea90188c76c6f7
DIST translate-3.13.4.gh.tar.gz 1173494 BLAKE2B 878da77378e4ca1a27c3053812b4f70c1decc55523421daa1716f10c4af9cc1d3d1a601bf076f343eaf34c661355af84dc2d173411779942e83eb4d7e64280f9 SHA512 44d0ee7d5e8b177034385bbc323539b8d53ef7a01d2431ea9c58a8df24ccc5f55af15f245b584db225e194b796d0281dec73ed66f50f8749cf949cb0a4c95277
+DIST translate-3.13.5.gh.tar.gz 1173710 BLAKE2B 1b6431cb0ce2643477c352f54dff0b7cbac8a79d3bf1e2a5976cdea649f8bbf3ee23f96ee97db1c5a7e57789ca5b434cddac959aeda92acaa75a0714b04bc507 SHA512 5ae243584f2bc4e3b304c6e0ccba2f4fcd3728964ed8361017241a787124dc24580ec842b3116036cd99f911f066e29559291b56893410f170d59f1e722e81a2
EBUILD translate-toolkit-3.13.3.ebuild 3179 BLAKE2B 409f83c60bb0088020da43f9d65708b9512b87ecb161ffe87ef323d7dcbe068ff709e7b97fbc628be3335fd983ff5231314716df63a1b0b9b92f4aefe3d1356c SHA512 299ef67dac4dc011cccc9f261b138433f70506240b231b63f8af5582584e1dda0c54acafb0e81ebdeb39de69253fd6c2db0756b7d7972c6eb04db9ea97e109b4
EBUILD translate-toolkit-3.13.4.ebuild 3182 BLAKE2B 98345bca852df50649e419889b3b65af580ba4919d5be0855057e745b87866b83f308e1eaa5bbe1192dd3b27337fbf7b36dca2cf76c3511b3324bc6ad8ce3394 SHA512 b10c4b4ed23d7a2794bb8ee04078157155e93a717151226fa8aa594a05b2ec7bb5cbf9d7ea45d40fcb8814cc7bbd47ece5fc823184b3946867311496a38aec6d
+EBUILD translate-toolkit-3.13.5.ebuild 3182 BLAKE2B 98345bca852df50649e419889b3b65af580ba4919d5be0855057e745b87866b83f308e1eaa5bbe1192dd3b27337fbf7b36dca2cf76c3511b3324bc6ad8ce3394 SHA512 b10c4b4ed23d7a2794bb8ee04078157155e93a717151226fa8aa594a05b2ec7bb5cbf9d7ea45d40fcb8814cc7bbd47ece5fc823184b3946867311496a38aec6d
MISC metadata.xml 756 BLAKE2B 06f64f258d362954f99f7e9eee241eb3dddc6b00b9069df2ad977d28b5cf06f9c8ee2246ee5958600b5ac86297968d7aaced6b6420dca4ed507c441c58c61ca9 SHA512 80374c40513ca450f97e3930929c1450e7438ea15830e60937952a6fccfd999675f2ca2056c5aa4e287ba256c6ec08a09d8f7adb8b2c5af8ca0cd595f34acd85
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.13.5.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.13.5.ebuild
new file mode 100644
index 000000000000..84540c3968c4
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.13.5.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="
+ https://github.com/translate/translate/
+ https://pypi.org/project/translate-toolkit/
+"
+SRC_URI="
+ https://github.com/translate/translate/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ >=dev-python/wcwidth-0.2.10[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+# Technically, the test suite also has undeclared dependency
+# on dev-python/snapshottest but all the tests using it are broken
+# anyway, so we skip them.
+BDEPEND="
+ test? (
+ dev-python/phply[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
+ # correctly, so we need to reassemble all data files in a single directory
+ local -x XDG_DATA_HOME=${T}/share
+ cp -r translate/share "${T}/" || die
+ cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ # all tests based on snapshottest are broken and I'm too tired
+ # to figure this out
+ tests/translate/tools/test_pocount.py::test_{cases,output}
+ tests/translate/tools/test_junitmsgfmt.py::test_output
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ tests/translate/storage/test_fluent.py
+ # changes directory and does not change it back, sigh
+ tests/odf_xliff/test_odf_xliff.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr
+ doins -r translate/share
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+}