summaryrefslogtreecommitdiff
path: root/dev-python/translate-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-01 07:44:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-01 07:44:56 +0100
commit910ec713340312b0b8437a7307c8effaa33fb410 (patch)
tree6223bae8a96d9bc13138d3a595aeda9182e64094 /dev-python/translate-toolkit
parent7714c84b341b3c783197e342fda2df5e579ac91f (diff)
gentoo auto-resync : 01:07:2023 - 07:44:56
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.9.2.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index e55c1360bb34..f6fce4a7ec43 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,5 +1,7 @@
DIST translate-3.8.6.gh.tar.gz 1158560 BLAKE2B 127083188e3f25551e1a55b4499fb2247e7fb7c751d813f6a78491ec2f1e457e0c18d3416cf05533d11e36201b36814054f4eaf94693d04351a0928a0347fa98 SHA512 271b34ac44835af2e50537ec5a6a5d4dff497fd3358fe53c92e800109a347206d544f71bee7181ec335736a462578913262ddfbb27d4bcef39f247338bc99134
DIST translate-3.9.1.gh.tar.gz 1175717 BLAKE2B 4d41b3de15de1f1611f5fbe05448c21943a5be3756af7594bd18a1f2da1c231dd2697d62a074cd6fec078a5178fb1116e359c720aa585fdb982b3f17afad62db SHA512 d38912046d522f0910149cea9a620f4378978bdff1366372681fa143f23764cf7c4d287fbc8713169d56f5d95c7048cfd34ab0ec560ca6dafbd18b45284d75eb
+DIST translate-3.9.2.gh.tar.gz 1175987 BLAKE2B 1d187f56f2cb003690038489bf2f788c8f60e9aef522642439f1ee169c7722f8b5646114e3fef2e6ba8f4b3a02ae27a58241c25a146dc6b0b7c8fbbe4044d1b5 SHA512 23c8238ee65ede57654e86e255608211b5f183b18bf7c2865fc5621a77619f1ad798b6e3be907adfa0db883b750db2d3be89001335d25afe6b259d8e91ba509c
EBUILD translate-toolkit-3.8.6-r1.ebuild 2295 BLAKE2B a8e851122065cfc5053ed8d50aa09d1afebbe1b3a0ba4b7a9f4129aaa0400ee77b4c4619aaa7f83488f691e141b1504e5cc8d082fbf832a3c6e2c052bfd78506 SHA512 feb37807713d699ac2b0b2bd4e9d44b070cfbf4ffab61a15553866b7c79c6939cbeb4cad3b7d6cbf96ff5b33b4dd4340fca9a0bbd88f1ecb25c20756cea9a5d5
EBUILD translate-toolkit-3.9.1.ebuild 3157 BLAKE2B 3fc67f1433d432c15cefd6bfab0a892993e5c54b73d8490f83caaa8e8dd88da311ef1a38eb00f41543fa34101228f1c972f85ce4e96d119b60e9fa6e1151391b SHA512 fbffa1c2b3ed79388fc1c8114754597d45a121a96275cd73afd159c10f81d7215919c1c828187dc46b551d4503c59b9084f0b28a8c1631e449aecea7c03183b2
+EBUILD translate-toolkit-3.9.2.ebuild 3157 BLAKE2B 3fc67f1433d432c15cefd6bfab0a892993e5c54b73d8490f83caaa8e8dd88da311ef1a38eb00f41543fa34101228f1c972f85ce4e96d119b60e9fa6e1151391b SHA512 fbffa1c2b3ed79388fc1c8114754597d45a121a96275cd73afd159c10f81d7215919c1c828187dc46b551d4503c59b9084f0b28a8c1631e449aecea7c03183b2
MISC metadata.xml 756 BLAKE2B 06f64f258d362954f99f7e9eee241eb3dddc6b00b9069df2ad977d28b5cf06f9c8ee2246ee5958600b5ac86297968d7aaced6b6420dca4ed507c441c58c61ca9 SHA512 80374c40513ca450f97e3930929c1450e7438ea15830e60937952a6fccfd999675f2ca2056c5aa4e287ba256c6ec08a09d8f7adb8b2c5af8ca0cd595f34acd85
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.9.2.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.9.2.ebuild
new file mode 100644
index 000000000000..2f01db02ab4e
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.9.2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="
+ https://github.com/translate/translate/
+ https://pypi.org/project/translate-toolkit/
+"
+SRC_URI="
+ https://github.com/translate/translate/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+# Technically, the test suite also has undeclared dependency
+# on dev-python/snapshottest but all the tests using it are broken
+# anyway, so we skip them.
+BDEPEND="
+ test? (
+ dev-python/phply[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
+ # correctly, so we need to reassemble all data files in a single directory
+ local -x XDG_DATA_HOME=${T}/share
+ cp -r translate/share "${T}/" || die
+ cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ # all tests based on snapshottest are broken and I'm too tired
+ # to figure this out
+ translate/tools/test_pocount.py::test_cases
+ translate/tools/test_pocount.py::test_output
+ translate/tools/test_junitmsgfmt.py::test_output
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ translate/storage/test_fluent.py
+ # changes directory and does not change it back, sigh
+ tests/odf_xliff/test_odf_xliff.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr
+ doins -r translate/share
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+}