summaryrefslogtreecommitdiff
path: root/dev-python/translate-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-17 06:41:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-17 06:41:55 +0000
commit6d730aa8064fbab6cc54447b6ed0e60b99c13256 (patch)
tree8c303cb48dc49dd218b79708ca71904653c5f831 /dev-python/translate-toolkit
parentcb2f73d10494730ba590096a1f24ebc6d0d61a9f (diff)
gentoo auto-resync : 17:01:2025 - 06:41:55
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.14.6.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 8c306e24745d..9ade3bd11eb5 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,5 +1,7 @@
DIST translate-3.14.4.gh.tar.gz 1174947 BLAKE2B 1a4f9b4b146145ef215ca0118c328c5c6153461b3f6899c665d1c69762bfe543ffffb7e590229b6d5ada5c5373b46484d4ebf6fbc4d9cac4b908174fde358d04 SHA512 4cb4b94f02858348c7e2e66cc3b0efa495084fbf03fb659ec701349f693c27647b11f2aefefca7b585b2c6e68a699149e85cedccbcf796e57edf825925e4f7d2
DIST translate-3.14.5.gh.tar.gz 1175068 BLAKE2B d3627d8a69f98d01fceb3d8e233ff9d19238ff42aa5255e5f4b8372ecacb07f1cea02ff75c6e7e27eec684eeda207db83b91c6905edf7b82d93ca1a275db4564 SHA512 40467e48aeca0a51caf6baabce13a3daa3b643a5416a1dc8b8ce70198b7b6f13688f808c0e050ca2e2e6d977347dab59b454b6d9c537b4d615f623d5531bcc10
+DIST translate-3.14.6.gh.tar.gz 1175486 BLAKE2B 3cfd844815adcd7ac24a41df41f3e717d7afa7c19f4e4467f9ce7892ec9adb321ed2e499358cdaa294c5a5d8ca8e20271ac47cc598b8e7585c290eea8e9b8235 SHA512 a2e23c4ec29e61fdcc0c28e7789478d595a11751c6117b7b5cc9191deec01e31309cea8a6e39c81635105b8b6b10c34533af5b91b736f7c2bbd4780146b79b3d
EBUILD translate-toolkit-3.14.4.ebuild 3179 BLAKE2B 7823612c89199b9c055e1d8bad2ec83f38196a9a8ec67a24f638a55b0bb5e0207b61f889c13fdae41634ff50c8e4f9994fc330aa2d9b0014b60f72e4f4970fe8 SHA512 b0e3a3795b4190b62c0ad2a73f399331ff3371e05eb820ada00b3f87efd8488a31c7dcdb3fe955be9ebd5840bfc5c7e6b41c7a5fada20b9698aa94874c60f08a
EBUILD translate-toolkit-3.14.5.ebuild 3182 BLAKE2B 77528e3b0cc671dadd87c5c74ed016d25880d7cd4e24da73825ddd533c6d54fcdac713d3403729c622ee84058e25f4ac0d8e80b46bb12944acb84cc68a4c1691 SHA512 dc0947fdfce8d3ccf7f01fa921c45c1f06292990158c9634855497f7864e14dc23b12c8d4aaa11fe7d02afb755a6b2a7915da838513ddc5a833f0774300d4b2f
+EBUILD translate-toolkit-3.14.6.ebuild 3182 BLAKE2B 132ece55534f73a3628579ccbdaf1b49ba1a59f3d84b5e015c2b0f277c005db79fe3009f568dc78b6b184ed4dcc0bd6f4be5a1ee62c75d3eff424d446d81a88a SHA512 75e13d61a98635ad89257c8979403298df7fc33df50f2bfc598b8db07e39648fa4120c08e4bf881bc79538d042d876d80411d10feaa2981e6a193cd63b450b56
MISC metadata.xml 756 BLAKE2B 06f64f258d362954f99f7e9eee241eb3dddc6b00b9069df2ad977d28b5cf06f9c8ee2246ee5958600b5ac86297968d7aaced6b6420dca4ed507c441c58c61ca9 SHA512 80374c40513ca450f97e3930929c1450e7438ea15830e60937952a6fccfd999675f2ca2056c5aa4e287ba256c6ec08a09d8f7adb8b2c5af8ca0cd595f34acd85
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.14.6.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.14.6.ebuild
new file mode 100644
index 000000000000..9af4d0313f20
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.14.6.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="
+ https://github.com/translate/translate/
+ https://pypi.org/project/translate-toolkit/
+"
+SRC_URI="
+ https://github.com/translate/translate/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ >=dev-python/cwcwidth-0.1.9[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+# Technically, the test suite also has undeclared dependency
+# on dev-python/snapshottest but all the tests using it are broken
+# anyway, so we skip them.
+BDEPEND="
+ test? (
+ dev-python/phply[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
+ # correctly, so we need to reassemble all data files in a single directory
+ local -x XDG_DATA_HOME=${T}/share
+ cp -r translate/share "${T}/" || die
+ cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ # all tests based on snapshottest are broken and I'm too tired
+ # to figure this out
+ tests/translate/tools/test_pocount.py::test_{cases,output}
+ tests/translate/tools/test_junitmsgfmt.py::test_output
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ tests/translate/storage/test_fluent.py
+ # changes directory and does not change it back, sigh
+ tests/odf_xliff/test_odf_xliff.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr
+ doins -r translate/share
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+}