summaryrefslogtreecommitdiff
path: root/dev-python/translate-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-06 10:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-06 10:25:44 +0100
commit64b277f858d171900cba8a53e675ef8c3ff893fc (patch)
tree7a19533ece87b58d4bbcc04d91701aaf888b0d99 /dev-python/translate-toolkit
parentededf7351b15c0df4d166af8fc7928bd1a0b2c8e (diff)
gentoo auto-resync : 06:09:2023 - 10:25:44
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.10.1.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 71b3acf86f0c..155290ef95ba 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,3 +1,5 @@
DIST translate-3.10.0.gh.tar.gz 1195239 BLAKE2B be1e2925632d032081a07cd99d540a90f4526810d5a9f587b4c651c41f7afe53ec212b408dfb81bf57a74fb286124c49b5b7f9f56a9c4b861c8874c7c6986532 SHA512 9669e4eccb68eab93ed7a35e2673df4f60bcc9602c4d97954180a8eb7e92ad9b82d2c8ef0caa8d8ce19ee2ae58e04867729bfd326c9e1a11a451d702372377fe
+DIST translate-3.10.1.gh.tar.gz 1197315 BLAKE2B 8cb9f78e505a7e6c737fa39e32c731313893d9016e14e79d565f2c68baecedd8be47bc4cc715000ee8dfcf094624b9b3a68a39800ec98908684dab8e8517448e SHA512 f3355603e445a432cb69f102a2ce4a20013b3df1a4c17c60a4599b069db6a0ad5316d29d79f211a61a1eb155dd550fb2db7c98e3f36dc858c5d15118cbeae8d8
EBUILD translate-toolkit-3.10.0.ebuild 3152 BLAKE2B f31981c7c11b1a55aca2a2fb6ec3d99515027614ea24f6733a81057d6addf8cf70daf8155f4dd4ba70350da496151c9d35c62b4a7b319b5770c04782e2b312a8 SHA512 53a16f4e03bf86db78f0d8dc1a7781f168e164b5fc57dca83b289d43689b47a5bd7aff0806b4d1a9e2d21862f9080deaf98d8ca7af7dfa9cb5de58a9204e754e
+EBUILD translate-toolkit-3.10.1.ebuild 3155 BLAKE2B d5b2adccda153b1b32d9014368ec7afe59ee3d906a4139a2b707a099ba35ed37225754e5a6fc8fa2aa1cef4c794907a32bf95c07b935c6f38c5e95dcebc0fa07 SHA512 a4ecf65621a93a494f892d2057bda1c81a779222113632d74c7deedebcfe8ecbcee531256059af9768ecf914a778ed9310cf5d6549f2ac95587f924eff4bbf4c
MISC metadata.xml 756 BLAKE2B 06f64f258d362954f99f7e9eee241eb3dddc6b00b9069df2ad977d28b5cf06f9c8ee2246ee5958600b5ac86297968d7aaced6b6420dca4ed507c441c58c61ca9 SHA512 80374c40513ca450f97e3930929c1450e7438ea15830e60937952a6fccfd999675f2ca2056c5aa4e287ba256c6ec08a09d8f7adb8b2c5af8ca0cd595f34acd85
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.10.1.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.10.1.ebuild
new file mode 100644
index 000000000000..e2c39f05b91c
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.10.1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="
+ https://github.com/translate/translate/
+ https://pypi.org/project/translate-toolkit/
+"
+SRC_URI="
+ https://github.com/translate/translate/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+# Technically, the test suite also has undeclared dependency
+# on dev-python/snapshottest but all the tests using it are broken
+# anyway, so we skip them.
+BDEPEND="
+ test? (
+ dev-python/phply[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
+ # correctly, so we need to reassemble all data files in a single directory
+ local -x XDG_DATA_HOME=${T}/share
+ cp -r translate/share "${T}/" || die
+ cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ # all tests based on snapshottest are broken and I'm too tired
+ # to figure this out
+ translate/tools/test_pocount.py::test_cases
+ translate/tools/test_pocount.py::test_output
+ translate/tools/test_junitmsgfmt.py::test_output
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ translate/storage/test_fluent.py
+ # changes directory and does not change it back, sigh
+ tests/odf_xliff/test_odf_xliff.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr
+ doins -r translate/share
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+}