summaryrefslogtreecommitdiff
path: root/dev-python/translate-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-08 22:21:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-08 22:21:23 +0000
commit4f8c8df3b07b6ea3556ab2bc7b252213bbdab3f3 (patch)
treeda90388e25f27949d16131813690edb36c53aa81 /dev-python/translate-toolkit
parent413ca4e6c2089d8b5e0844c26cf5671209226b93 (diff)
gentoo auto-resync : 08:11:2023 - 22:21:23
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.11.0.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 7395d8a49c38..1af03ed5700c 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,4 +1,6 @@
AUX translate-toolkit-3.10.1-py312.patch 1518 BLAKE2B 93024929524479ac6d42558b642da725d39668ecf9bf6bcc4f96707cc1888982270a45af57d3d08b5364b17ed12bd20bb11097ea2dd7ec1e738458b4610f4be8 SHA512 c2201b9a2d98cbee2593024675066009b21ba46856b1c7d50962cafe5ad4fc87a7578aa6779478c16ebaedbdd472635aab932f05124df3e3216bfca1601c755f
DIST translate-3.10.1.gh.tar.gz 1197315 BLAKE2B 8cb9f78e505a7e6c737fa39e32c731313893d9016e14e79d565f2c68baecedd8be47bc4cc715000ee8dfcf094624b9b3a68a39800ec98908684dab8e8517448e SHA512 f3355603e445a432cb69f102a2ce4a20013b3df1a4c17c60a4599b069db6a0ad5316d29d79f211a61a1eb155dd550fb2db7c98e3f36dc858c5d15118cbeae8d8
+DIST translate-3.11.0.gh.tar.gz 1197440 BLAKE2B 8443135619bfed752db883a7fab17efb2860c0cf5d42d5345be80c7b4a17c3764f56ed01f5e77c26984155f0c24e61b7f6a2ec852093b17ae2e8c62cb0abf9c0 SHA512 a542fac267a931e0b92c18fc9eef094c7ab2d78ea366b58880e63e1421dd914f06eb1618d178d8e586b0040003d3fec5aebde705b8715b773bd0e3a91b73b841
EBUILD translate-toolkit-3.10.1-r1.ebuild 3287 BLAKE2B c864f117c4e2e1a040bcc5cc8fa8edd01e5228ae9723289851513c48b41056784192a8796d245295821e78ebc050c869c4427b33084d96e92dcc37278967ba5d SHA512 71323866bcfe6294b24876f2a0127e20c26b055b12fcbe5bc3e9f55730139a656d2e2fadef30cb34e642527a135f1ee4b1a99e94b4a602ca46837a3577e1814a
+EBUILD translate-toolkit-3.11.0.ebuild 3135 BLAKE2B a1a9eb35eeb14727e9d4efdfcccf9baf5bd62a7701a26e85905753610b8be20a6f86d45d855ad4464c6352857c70e5b0a9b9f061c123fec64221f88348f01ea5 SHA512 1191f473eace930f5d600e53c822109b526e5adc0af7173cce1ad453f226da86c428c4891155c026bf2e1f69a88ac5c710ffb12a806fd41d29bbf094ed24055a
MISC metadata.xml 756 BLAKE2B 06f64f258d362954f99f7e9eee241eb3dddc6b00b9069df2ad977d28b5cf06f9c8ee2246ee5958600b5ac86297968d7aaced6b6420dca4ed507c441c58c61ca9 SHA512 80374c40513ca450f97e3930929c1450e7438ea15830e60937952a6fccfd999675f2ca2056c5aa4e287ba256c6ec08a09d8f7adb8b2c5af8ca0cd595f34acd85
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.11.0.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.11.0.ebuild
new file mode 100644
index 000000000000..9bf1ba95a909
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.11.0.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="
+ https://github.com/translate/translate/
+ https://pypi.org/project/translate-toolkit/
+"
+SRC_URI="
+ https://github.com/translate/translate/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+# Technically, the test suite also has undeclared dependency
+# on dev-python/snapshottest but all the tests using it are broken
+# anyway, so we skip them.
+BDEPEND="
+ test? (
+ dev-python/phply[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
+ # correctly, so we need to reassemble all data files in a single directory
+ local -x XDG_DATA_HOME=${T}/share
+ cp -r translate/share "${T}/" || die
+ cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ # all tests based on snapshottest are broken and I'm too tired
+ # to figure this out
+ tests/translate/tools/test_pocount.py::test_{cases,output}
+ tests/translate/tools/test_junitmsgfmt.py::test_output
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ tests/translate/storage/test_fluent.py
+ # changes directory and does not change it back, sigh
+ tests/odf_xliff/test_odf_xliff.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr
+ doins -r translate/share
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+}