summaryrefslogtreecommitdiff
path: root/dev-python/translate-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/translate-toolkit
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.5.3.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 8bb478d0afaa..dc3c50242ab5 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,6 +1,8 @@
AUX translate-toolkit-3.3.0-no-install-docs.patch 652 BLAKE2B 202cfd408059115cfdb5933320b5a560eeee37e2c045cedcdd80cf808ab1e1a5569a964e9eab8114a2ab27e2c470285b254406c754b5289f7cff2f22afcebb6c SHA512 d98e2d7519ca630d41407d01f20543a84c3f408628832d4e79a5a52437d204f872aaef8eca80687565e6981dddb59480a313217eddf8a4084d8b6d71c3d2c0da
DIST translate-3.5.1.gh.tar.gz 1147898 BLAKE2B f9fc96065727e0016e61fd581690dafc3021471de9ccc9012b223c24778669b984e0bf0ab5f83a910af0e543b0e4793afa110c5b2ced890a257f72512bcaf58d SHA512 2125e3ab019a6b721327d6979482562d5984df28b04aaa69d11e44b6a7396ee387f79d8242a20a84157f9b62457839b52599eb0fe13abac33c9a312a84d55d30
DIST translate-3.5.2.gh.tar.gz 1147847 BLAKE2B 6ca8458975018c3645f3fcead99812b5f91c2a3e621060c1cf9599ecd2fdee8914ae1d70b70f8bc76f5d941f43e69e55555a35a5792d0c8c9d9e06458e670617 SHA512 e04c195d0f33aaf9c2368955c4c399be3c23702ce0fcb41705f727b65e129b652b5637a9b56ad2879f836548b77c266382ce41220a23aa9058828ee2f2ba1b3e
+DIST translate-3.5.3.gh.tar.gz 1148120 BLAKE2B e848a089281ab7f1e17b28beefbea50245025bc3db0616bab3f5e1d288b2aacc0df636dca11f17481af863a4845594ecff9fc66dbc33d403a8fe0575ff90581d SHA512 3ad1bc4742e4d91dbdd8b4662597d07c792e306426dac42b6f8720cefdf1f4cf502d587941df3e6a93dd5648a1b92f5951bd1b5e79a41e5476f1b9ca06624656
EBUILD translate-toolkit-3.5.1.ebuild 2552 BLAKE2B 869dbfc79a91565e7a340d6e743f6cad1f1e46a0d5550fedc49cae0d87ae393347da7eab091f36375bed52ca2f326645c576f8fdf11a8219f991d6142fabd8f1 SHA512 824a78b456dfecf137d5b561b77710f2183dd2552eda82ea4777f9513905a014523df19d56e2c84517a7b1fe316969ba526ea17e4a45db6f95e59b07dd1003fb
EBUILD translate-toolkit-3.5.2.ebuild 2557 BLAKE2B daf364d5d0ecd9be5c5023912159b449b61bbfc892063923ad00ebacc57f1edb68ce66052ba89a483bd7b5771e5408b7306c2b8dbdbf9c776878a71669ba8346 SHA512 ce8c0d106ecc240dff8e52a53bd8352e6910af0191fbeaea446bcd40963fbaaa5290ee7f03147dfea1498ff6ff6f88822ec629d3fddd9ea1e3f92f41c0157ddf
+EBUILD translate-toolkit-3.5.3.ebuild 2557 BLAKE2B daf364d5d0ecd9be5c5023912159b449b61bbfc892063923ad00ebacc57f1edb68ce66052ba89a483bd7b5771e5408b7306c2b8dbdbf9c776878a71669ba8346 SHA512 ce8c0d106ecc240dff8e52a53bd8352e6910af0191fbeaea446bcd40963fbaaa5290ee7f03147dfea1498ff6ff6f88822ec629d3fddd9ea1e3f92f41c0157ddf
MISC metadata.xml 746 BLAKE2B d11f99224b1dd6ccb5a64b2f3346f3963f7874197fc5cd13a9bc84036d7f6d78e62d4f92d80b41b3a71426978c605d599207ba7d20ee94ca195e6be3b60f41cb SHA512 07dfd2ab55c6eb0ab346e66a3f03dd82e193382c6bdec0d2b8826cde7e4e11bb5d6f3bc1a5885b08d9c2aa51f8afedc6ec6684f224951e6dd80bc500c783cbb3
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.5.3.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.5.3.ebuild
new file mode 100644
index 000000000000..768d499ebbb3
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.5.3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="https://github.com/translate/translate"
+SRC_URI="
+ https://github.com/translate/translate/archive/refs/tags/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND=">=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}
+ !dev-python/pydiff
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
+ >=dev-python/python-levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+BDEPEND+="
+ test? ( dev-python/phply[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-bootstrap-theme
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/translate-toolkit-3.3.0-no-install-docs.patch
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ translate/storage/test_fluent.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ # translate/storage/test_mo.py needs 'pocompile'
+ distutils_install_for_testing
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+
+ python_optimize
+}