summaryrefslogtreecommitdiff
path: root/dev-python/traits
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/traits
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/traits')
-rw-r--r--dev-python/traits/Manifest5
-rw-r--r--dev-python/traits/metadata.xml26
-rw-r--r--dev-python/traits/traits-4.5.0.ebuild38
-rw-r--r--dev-python/traits/traits-4.6.0.ebuild40
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/traits/Manifest b/dev-python/traits/Manifest
new file mode 100644
index 000000000000..ea0224387e7b
--- /dev/null
+++ b/dev-python/traits/Manifest
@@ -0,0 +1,5 @@
+DIST traits-4.5.0.tar.gz 4853612 BLAKE2B 6c3d83718751de1e0553487a45d073c285ada96686558133fe61472c29c3d4661e1c0bce68340bada9667f3f9e0c8ed11050a714bc0c55424dbd4ebd17e3ad8e SHA512 d506b4395395898eb824896d299bfcde609e100025cf9a55cd7d7c47615545efd3b007e46549e564fbfb2d5882b36ae676843f211f168b2557c504849c5ef582
+DIST traits-4.6.0.tar.gz 434937 BLAKE2B 91d457b411f78b74a077f3bfaa8e3f627d0ddb959784ba0ce9e07e3fc8b76cddcaee1fd7293d8336c4fc0630d49527fd29e1a9ccba6b724846069f6282c643e8 SHA512 0fce336696e4cbb1d4ba63a07ad42867cb179a9efa6c348623036bd6d2eb791302539ae89994b11acd5a9f1be42a0febeb517db1716342b78aa71ca1277fde99
+EBUILD traits-4.5.0.ebuild 894 BLAKE2B 2baa2e7b5e93f71a886c9ac089b3c53e00a1b530644e395a972f8d738e5bef675c33c326083f568a5f5a57417b8bce8fb1a31a367d065efc312b4a648d121737 SHA512 a9cbe9b572b8fcbf31f5cf5b4843da932fcd51715be442ff4e254b557e598a7c0368d47e76ad91e6c7ca8c44f6669c95e880708864780b46774394b7494c72a1
+EBUILD traits-4.6.0.ebuild 932 BLAKE2B 7c719c6d90d94fada4377df54aeff1ef79c2f7de72ebe49e971c2b2462594fc8ddea7e0c6690e466f22f2c5e0961d0aaa3736d40e756124823dc7424f81ae4f9 SHA512 89c16f359e680c1cff9c853f25d81fb660f1f479a22591ddd505c74c43b9f95658f7934ee6a1128f582c3594bd19df7131e53bccd6d448dbeabd0f163b716b0a
+MISC metadata.xml 1133 BLAKE2B 22ceede6128cc9a0688d4d827512b118a674e95492f889a5b8c3042811fcea27020f7696752905e5cb6e57015c838f7b9beeccdbab8f90f93d6c91ac04b023b4 SHA512 4cbab7c0b05c5d13b70caa8bb5c6bb080e5490adee2e3a81c28699ff455969e3f0a8784b4278621b01aa9c16a334e7bfbe0a8d0558f6162555cff86704b11570
diff --git a/dev-python/traits/metadata.xml b/dev-python/traits/metadata.xml
new file mode 100644
index 000000000000..0e2713e3142b
--- /dev/null
+++ b/dev-python/traits/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The traits package from the Enthought Tool Suite provides a
+ metaclass with special attributes that are called traits. A trait
+ is a type definition that can be used for normal Python object
+ attributes, giving the attributes some additional characteristics:
+ * Initialization: A trait attribute can have a default value
+ * Validation: A trait attribute is manifestly typed.
+ * Delegation: The value of a trait attribute can be contained in another object
+ * Notification: Setting the value of a trait attribute can fired callbacks
+ * Visualization: With the TraitsUI package, GUIs can be generated automatically from traited objects.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">traits</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/traits/traits-4.5.0.ebuild b/dev-python/traits/traits-4.5.0.ebuild
new file mode 100644
index 000000000000..aa0e34305e32
--- /dev/null
+++ b/dev-python/traits/traits-4.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="http://docs.enthought.com/traits/
+ https://github.com/enthought/traits
+ https://pypi.org/project/traits/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ sed -i -e "s/'-O3'//g" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ nosetests || die
+}
diff --git a/dev-python/traits/traits-4.6.0.ebuild b/dev-python/traits/traits-4.6.0.ebuild
new file mode 100644
index 000000000000..d3d48e925b4f
--- /dev/null
+++ b/dev-python/traits/traits-4.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
+HOMEPAGE="http://docs.enthought.com/traits/
+ https://github.com/enthought/traits
+ https://pypi.org/project/traits/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ sed -i -e "s/'-O3'//g" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ nosetests || die
+}