summaryrefslogtreecommitdiff
path: root/dev-python/traceback2/traceback2-1.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/traceback2/traceback2-1.4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/traceback2/traceback2-1.4.0.ebuild')
-rw-r--r--dev-python/traceback2/traceback2-1.4.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/traceback2/traceback2-1.4.0.ebuild b/dev-python/traceback2/traceback2-1.4.0.ebuild
new file mode 100644
index 000000000000..0a92ea3f616d
--- /dev/null
+++ b/dev-python/traceback2/traceback2-1.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Backports of the traceback module"
+HOMEPAGE="https://github.com/testing-cabal/traceback2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+"
+RDEPEND="dev-python/linecache2[${PYTHON_USEDEP}]"