summaryrefslogtreecommitdiff
path: root/dev-python/traceback2/traceback2-1.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /dev-python/traceback2/traceback2-1.4.0-r1.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'dev-python/traceback2/traceback2-1.4.0-r1.ebuild')
-rw-r--r--dev-python/traceback2/traceback2-1.4.0-r1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/traceback2/traceback2-1.4.0-r1.ebuild b/dev-python/traceback2/traceback2-1.4.0-r1.ebuild
deleted file mode 100644
index 764320ce82f6..000000000000
--- a/dev-python/traceback2/traceback2-1.4.0-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Backports of the traceback module"
-HOMEPAGE="https://github.com/testing-cabal/traceback2"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/linecache2[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- dev-python/contextlib2[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # fails by line numbers on various py3 versions
- sed -i -e 's:test_context_suppression:_&:' \
- -e 's:test_format_locals:_&:' \
- -e 's:test_bad_indentation:_&:' \
- -e 's:test_encoded_file:_&:' \
- traceback2/tests/test_traceback.py || die
- distutils-r1_src_prepare
-}