summaryrefslogtreecommitdiff
path: root/dev-python/tqdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-11 05:34:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-11 05:34:35 +0000
commite644f875e1d27155e8829b8f7385a8b2d790bcce (patch)
tree34f399ec8067712dc6b5416ac39685d1999649c7 /dev-python/tqdm
parent0771aa27d30f102abe2c5733a138ffe570da4d15 (diff)
gentoo auto-resync : 11:02:2024 - 05:34:35
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest2
-rw-r--r--dev-python/tqdm/tqdm-4.66.2.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index ed33a9b1c6f0..cc6d02b3a7f6 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,5 @@
DIST tqdm-4.66.1.tar.gz 169147 BLAKE2B 4b274badaa13feb55ff079e143ec5a539a2ad1e1ed60fb319b8f955cfb5baa26676773c0d4fee95c6ad0f068434eadd80bee97559d0c0fdc8c74ea890781f589 SHA512 989bc93f791e1636525486688b1d9b457314cde7b5804018382cc490638ac0b88aac50d7870beb9dd80bc5f05e083b8f9f205ac17324106f6d936bfe8d2f316e
+DIST tqdm-4.66.2.tar.gz 169462 BLAKE2B 57a1e5895ed2e1f99246fd6bdfc08fb75a24451e358bbf38324cdcfe35559b6748dbe63dcdaf65024b12165daa404c98d5b6db81673e7d0f930142cab1b623d7 SHA512 49abd9006ca7c8672835b202e4e722602035a0e21723337b4227e114d6d50b678edb6c5f2b0cf4e6741eae5e86551ba59233f87989f6b69bb4d4414d5a3c80e5
EBUILD tqdm-4.66.1.ebuild 1001 BLAKE2B 733e92b55eab154db5570f6faa294a8e3c1f457ea5fefe2cc1c696f50cfbeebbe9f89c1bde6ee75078f37c07f4ed8638b42309c7edea93d73081a1733b5238c2 SHA512 0730bb760aa2df3449d9c2f62ed913748e2abecca0e9b199499550d232e627c8cc50e93f3eef3fe502a5c89382790a9db8a57eb6f70d26383faef84b98491fe8
+EBUILD tqdm-4.66.2.ebuild 1009 BLAKE2B e5f18f53819bedf6f0e9780accb20d1f85658cbd418444cffe60b947efb13aed703a5c56d99691e2e26d5c8b30c648ad435c4606efe40097d86d36d8ba769b52 SHA512 9975db34248f5a3131cd9dc5b60c1321079e11916461f8581edb884254856fa45eb9de5fdd30d882bd4d22d833fdb82013ce9ad30b208e4a1728104173ea71cc
MISC metadata.xml 605 BLAKE2B ed20e6f11f20cdc6525b98d9fd37c0b8f0781dd1c4be85e8aa4a3f5644a20fde3179bd44bb99ef4c14913168113a58963b36281ccf4807a694624a1e2df578f8 SHA512 b5f096a0256312e6ab5098bb6d9965b567bd735813d9c97fa49f08de640f2c5ebb292ba747eb284ff043dc29d4bb1cab1ac947ecaab6b4e94aa51e96a0cac636
diff --git a/dev-python/tqdm/tqdm-4.66.2.ebuild b/dev-python/tqdm/tqdm-4.66.2.ebuild
new file mode 100644
index 000000000000..1f7508033f3b
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.66.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}