summaryrefslogtreecommitdiff
path: root/dev-python/tqdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-04 22:23:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-04 22:23:05 +0100
commitcb259c03daeefbbc0a46d61314d25be7edeb14e8 (patch)
treee228a8c4418efcbf6d2bcf37aa9f01bd1b4eb43b /dev-python/tqdm
parent86eece26841510c190c0b254a24efc4d6b42acec (diff)
gentoo auto-resync : 04:09:2022 - 22:23:05
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest2
-rw-r--r--dev-python/tqdm/tqdm-4.64.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index fbc8f9db2139..6662a59d9c78 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,5 @@
DIST tqdm-4.64.0.tar.gz 169499 BLAKE2B a6b9587a366c026716c63af4358ddba693b52be3490a161071bc750fffcd50429bc639255635d96c950a130d9fe994dc2abc98f3fbaf0a0c344140c8ae972596 SHA512 84d243b86ea3665e915e6a79e7887a4d0487b166971d211e34229b7a46429f4e4f5808c03f24420b20fb85d274e1e6b36ed852af99c5c9d177c8ce71f0ce0c17
+DIST tqdm-4.64.1.tar.gz 169599 BLAKE2B 4c48f647beb46f22e3c065e2e9c1dc29755c74a2fd29cb8ad8b0dfeab529499d0fbca9296d06453012b3bbf9f9870f95da5e2f37f4c8ba29a71cbee3bd15116b SHA512 bc7ab34145722229737d25d87895c8760b82271c345e1174c83f5896cc893f92a27901d83575472ad124329acdad69bd21e7d68e79aeeefb0e66c83b11989d18
EBUILD tqdm-4.64.0.ebuild 1027 BLAKE2B 041bdf83495e00ae3f9f61ffb4bb21b567ee090e65b0fa9fbaf171adb2f84c15bbc1057738e8a0f11fe8e0eb4afafcb9af14603f7f436edf8b0e1681f32ff346 SHA512 25f63eac901dd11d00b40a962c08dbcc44fc793e9bc33d5e5cdf2aaa893412e9dab34c524d1ea099b4ac5f01af16d7335a27edba1c772fb5a5281e39a868a5f6
+EBUILD tqdm-4.64.1.ebuild 1035 BLAKE2B 6c73a23cca261d86c9adb2ee845f83a825e6686a87ed7d062169a84dcb8c07bbab91d310db59724adc3e630e9f981e2c82a0c8f3d46063da90156515007b6c52 SHA512 4f6df9b6119a454edfde033d8cee867d622c5f8b4651c0c2ae6f85cbc95cc4b2331464247f979a8fb869c7cea4c5d8186d43926e033aa8b03884ba74b4dcfa50
MISC metadata.xml 605 BLAKE2B ed20e6f11f20cdc6525b98d9fd37c0b8f0781dd1c4be85e8aa4a3f5644a20fde3179bd44bb99ef4c14913168113a58963b36281ccf4807a694624a1e2df578f8 SHA512 b5f096a0256312e6ab5098bb6d9965b567bd735813d9c97fa49f08de640f2c5ebb292ba747eb284ff043dc29d4bb1cab1ac947ecaab6b4e94aa51e96a0cac636
diff --git a/dev-python/tqdm/tqdm-4.64.1.ebuild b/dev-python/tqdm/tqdm-4.64.1.ebuild
new file mode 100644
index 000000000000..79761eab6850
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.64.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}