summaryrefslogtreecommitdiff
path: root/dev-python/tqdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-python/tqdm
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest4
-rw-r--r--dev-python/tqdm/tqdm-4.62.2.ebuild51
-rw-r--r--dev-python/tqdm/tqdm-4.62.3.ebuild2
3 files changed, 2 insertions, 55 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index d8600b9f64af..082ad7bc087b 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,5 +1,3 @@
-DIST tqdm-4.62.2.tar.gz 169564 BLAKE2B fd3484db22eda5db7431fc337e23cfcf44882efc56c8b10208d799c156fefb5aa70c69c7063315d86d3ff881b97b62ac0b5c8be73ad3546ad0728f3f544cadfa SHA512 a59a041fa239e215e541f07c66292c27bfe067f3f2eac2916662b4ef1faa630346dec9558a7f66a3456b3d2ddcd164f9381cb89e5ac8350d0295367bfc248a8c
DIST tqdm-4.62.3.tar.gz 167952 BLAKE2B d5732fc97256e1fc4f55bd1a0f69f98a87e7132cc1d8484baa12b7615da5a95ce20268515539c595c2b2aaf20f9a9434c17d581b3b90ea3cad3515150e469471 SHA512 1083ca2080163c98bbb55e124ce9d47c790e47c83cd8dad60e4c93773d1d97a50aacb5a25ddb8a2ae3691738e4f4942c88d55dab406c3e810cac18b8929d20ee
-EBUILD tqdm-4.62.2.ebuild 1162 BLAKE2B 1c239c6f6202c694f1acbda28820226d91f9905c055ca5639f3f896293078271ba79acf3e10dd5b8e4dcf9a6abd20bfc5a7bf2bb3c171122d724866d27e6f7ba SHA512 10d7735f0c6a7f22caaf0f59bb915b4bb0ce0a04531f15850316dbb5a4ff17aa614b0b37934324c2f7f3dc9e530a79dc6ef2d2a657c5888155da1fd2b9b54f85
-EBUILD tqdm-4.62.3.ebuild 1170 BLAKE2B 2409955943a44f519894be995f246cb779fed309aa1a6be85c4a73fe1c5bd622d92ff3debd3da955804c83ec269a3d01fa6ef8bd1248f25bbdc950e37c4129d2 SHA512 aa59e6ebbef2545054fb3cd3606e55b3c9267af575302b1975d956d15ec2457b7cd46f3657e8e46f63e5f0c6bdfacbb3f5e02122a42c66c5781133eab0678046
+EBUILD tqdm-4.62.3.ebuild 1162 BLAKE2B 1c239c6f6202c694f1acbda28820226d91f9905c055ca5639f3f896293078271ba79acf3e10dd5b8e4dcf9a6abd20bfc5a7bf2bb3c171122d724866d27e6f7ba SHA512 10d7735f0c6a7f22caaf0f59bb915b4bb0ce0a04531f15850316dbb5a4ff17aa614b0b37934324c2f7f3dc9e530a79dc6ef2d2a657c5888155da1fd2b9b54f85
MISC metadata.xml 605 BLAKE2B ed20e6f11f20cdc6525b98d9fd37c0b8f0781dd1c4be85e8aa4a3f5644a20fde3179bd44bb99ef4c14913168113a58963b36281ccf4807a694624a1e2df578f8 SHA512 b5f096a0256312e6ab5098bb6d9965b567bd735813d9c97fa49f08de640f2c5ebb292ba747eb284ff043dc29d4bb1cab1ac947ecaab6b4e94aa51e96a0cac636
diff --git a/dev-python/tqdm/tqdm-4.62.2.ebuild b/dev-python/tqdm/tqdm-4.62.2.ebuild
deleted file mode 100644
index dd8d2f22d61c..000000000000
--- a/dev-python/tqdm/tqdm-4.62.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/tqdm/tqdm"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
-fi
-
-DESCRIPTION="Add a progress meter to your loops in a second"
-HOMEPAGE="https://github.com/tqdm/tqdm"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="examples"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- # Skip unpredictable performance tests
- epytest --ignore 'tests/tests_perf.py'
-}
-
-python_install() {
- doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
- rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
- distutils-r1_python_install
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/tqdm/tqdm-4.62.3.ebuild b/dev-python/tqdm/tqdm-4.62.3.ebuild
index be993f734871..dd8d2f22d61c 100644
--- a/dev-python/tqdm/tqdm-4.62.3.ebuild
+++ b/dev-python/tqdm/tqdm-4.62.3.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/tqdm/tqdm"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
fi
DESCRIPTION="Add a progress meter to your loops in a second"