summaryrefslogtreecommitdiff
path: root/dev-python/tqdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
commit7f3fecbb5b871825fe9632f46659869cab6a3769 (patch)
treedd2be4fe7ee3475ca4ad093698f0f8fd1e0965dc /dev-python/tqdm
parenta98588cfddf3d6e88a5f17d7f399b695163c7a85 (diff)
gentoo auto-resync : 04:05:2024 - 00:00:19
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest2
-rw-r--r--dev-python/tqdm/tqdm-4.66.4.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 12d9a28cfbf5..936407ac67c0 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,5 @@
DIST tqdm-4.66.2.tar.gz 169462 BLAKE2B 57a1e5895ed2e1f99246fd6bdfc08fb75a24451e358bbf38324cdcfe35559b6748dbe63dcdaf65024b12165daa404c98d5b6db81673e7d0f930142cab1b623d7 SHA512 49abd9006ca7c8672835b202e4e722602035a0e21723337b4227e114d6d50b678edb6c5f2b0cf4e6741eae5e86551ba59233f87989f6b69bb4d4414d5a3c80e5
+DIST tqdm-4.66.4.tar.gz 169392 BLAKE2B 6d8e3e9775d93d9c064289b8a830b4f541a753a48044ec65fcee9c8d158d423e362d06c3404efce67de28fab2c3f1fb3d8aaa0fdec33b4d040ad1f2aec97fde2 SHA512 fdafa64784564f7f400f29ffa75ba564a3c9bc6d935a1ccd82260d4a1f4431792a9dae2d5c6ed69cc265f078f674081589a040d47b8745a500870d27670feadc
EBUILD tqdm-4.66.2.ebuild 1001 BLAKE2B 6092212048388f6e1059bef1f1076effc9f4d90c46da533f72d5e34795af5c72493a7a9375f878b9cd305e00cc659432fd75045a401bc8fe4eee0ba884384449 SHA512 ce7cc2da4c0bf1231f2f8a38a87ee4072b1c490040facabf32f3131bc4d1c7854d7549aa1f7ee453ce76e8c6f666adcd0723a32d3a94b8e75cc6d00178606b85
+EBUILD tqdm-4.66.4.ebuild 1009 BLAKE2B e5f18f53819bedf6f0e9780accb20d1f85658cbd418444cffe60b947efb13aed703a5c56d99691e2e26d5c8b30c648ad435c4606efe40097d86d36d8ba769b52 SHA512 9975db34248f5a3131cd9dc5b60c1321079e11916461f8581edb884254856fa45eb9de5fdd30d882bd4d22d833fdb82013ce9ad30b208e4a1728104173ea71cc
MISC metadata.xml 605 BLAKE2B ed20e6f11f20cdc6525b98d9fd37c0b8f0781dd1c4be85e8aa4a3f5644a20fde3179bd44bb99ef4c14913168113a58963b36281ccf4807a694624a1e2df578f8 SHA512 b5f096a0256312e6ab5098bb6d9965b567bd735813d9c97fa49f08de640f2c5ebb292ba747eb284ff043dc29d4bb1cab1ac947ecaab6b4e94aa51e96a0cac636
diff --git a/dev-python/tqdm/tqdm-4.66.4.ebuild b/dev-python/tqdm/tqdm-4.66.4.ebuild
new file mode 100644
index 000000000000..1f7508033f3b
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.66.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}