summaryrefslogtreecommitdiff
path: root/dev-python/tqdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-09 09:29:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-09 09:29:40 +0100
commit6e9fa3a4a14685a33fc9182895e5529c293bae2e (patch)
tree8a9be21a286aa4d45a2169e1d77a8d7defc17847 /dev-python/tqdm
parent0b39c3b03f13c084074099704a673640904e5249 (diff)
gentoo auto-resync : 09:08:2023 - 09:29:39
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest2
-rw-r--r--dev-python/tqdm/tqdm-4.65.2.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 1ae2e78aa700..6b7ba8d4d1a3 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,5 @@
DIST tqdm-4.65.0.tar.gz 167542 BLAKE2B b1f7b5666600dd5c476ffc9852cdc8905b8819b6b3f812e00495fa38780dda0c59e48956881d46919ce57b13da9dde519fa7e22d91ed58fe43172da8e9043653 SHA512 86315b57d8ceec69ee8970b25372b26b03d2d37f6d06e037e712bf16c7f56eac1c4049291e451c7df62273b91ba7149b400efd0186ceee90268d854e7b476c47
+DIST tqdm-4.65.2.tar.gz 167099 BLAKE2B 5b3d1444aacd3ffa46149889ed5eee3bc851da2c000fcfbd06ceda811ad6df3fd7f9b5da90e7124930ebfd8249a52d194d807d7f8e8b1170966d2b1e6128fc7b SHA512 012810c5844f4034388469a4ce71382067a42960a534e2720d412483b3668040367e94c1865dcd44855cf1f2c7e28312b6084d579348492d7ca3ba5241395f40
EBUILD tqdm-4.65.0.ebuild 1001 BLAKE2B 733e92b55eab154db5570f6faa294a8e3c1f457ea5fefe2cc1c696f50cfbeebbe9f89c1bde6ee75078f37c07f4ed8638b42309c7edea93d73081a1733b5238c2 SHA512 0730bb760aa2df3449d9c2f62ed913748e2abecca0e9b199499550d232e627c8cc50e93f3eef3fe502a5c89382790a9db8a57eb6f70d26383faef84b98491fe8
+EBUILD tqdm-4.65.2.ebuild 1009 BLAKE2B b11f09e427912bb7fc295197ea307dba890863609a0772664407596795a51d470bf8fe27022dece8c3c742f9a963aacbbb0ccaa510cb99ad61ce6798a2c13628 SHA512 c05f10016774f07254b41f950d1922b2043207f899bf1fbc1bc95c17d5fc2a0fdfb6e40391adcd9c3b8b2d8133d78fa0b4dd9939c4f35391e12ec4dc2e806947
MISC metadata.xml 605 BLAKE2B ed20e6f11f20cdc6525b98d9fd37c0b8f0781dd1c4be85e8aa4a3f5644a20fde3179bd44bb99ef4c14913168113a58963b36281ccf4807a694624a1e2df578f8 SHA512 b5f096a0256312e6ab5098bb6d9965b567bd735813d9c97fa49f08de640f2c5ebb292ba747eb284ff043dc29d4bb1cab1ac947ecaab6b4e94aa51e96a0cac636
diff --git a/dev-python/tqdm/tqdm-4.65.2.ebuild b/dev-python/tqdm/tqdm-4.65.2.ebuild
new file mode 100644
index 000000000000..0472066fc4d2
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.65.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}