summaryrefslogtreecommitdiff
path: root/dev-python/tox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
commit9a8514e070a40648dbc8e28ad6457d925542b79a (patch)
tree5cc8ed0b0c8964ad196b7b3e502def202a997b32 /dev-python/tox
parent2ecd7994be1409f2a65bfca700904d2a78fd7bbe (diff)
gentoo auto-resync : 26:10:2022 - 09:55:31
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest2
-rw-r--r--dev-python/tox/tox-3.27.0.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 4c679e16e173..70b77f39d7d6 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,3 +1,5 @@
DIST tox-3.26.0.gh.tar.gz 308035 BLAKE2B 745d1aef11c230971a7b6b1df919440c2be1b9b0f726ab314e1a27fe6fa72b568efc8e336058249721028cc18d2c3453e4806079abb8099baa608bf6b1e98ad7 SHA512 8c2635a640bcc221735f59da633b3ae696d97c076280400f6086703c2e00d8dbad943073e0c63618e5e041199dfebd010a16a00b1498ca9ea8e884648ed40ae5
+DIST tox-3.27.0.gh.tar.gz 308774 BLAKE2B efb3d40aa3045f984fd2534124de506c166fc8fde46d655c608ffcb7a85637ebda5c8bdef6cf4d414d84433fd361143fb91f98877d8112489c479049ec4f01be SHA512 e42cb0c203afb053c8bd6b29e90384fe6c32ab2ee3fb64fe0323474ca0b7f94d3e035d9d15218da28bc93d852c5f266c04b89d4b38db7d843d1098207f99a9bf
EBUILD tox-3.26.0.ebuild 1916 BLAKE2B ab2496317d588c05936d57132d1c759c9a14f18c10fb50d6188b7bee5bd20de9f06b5d8945a908cbf021f4b7036ba6d23dcf19aad63af9d6cd6bf6baa598ad32 SHA512 b038f9976de8af46ac663faa169a06fad1bd28ef61738679fd70faa5e655c0c85ed3a8e4efddee2dd2aff8cc3fe9f5ec133311d122c6bab15c487a5a074a6c11
+EBUILD tox-3.27.0.ebuild 1924 BLAKE2B d2a5ac59691e8ad704bb64840925d192df827d533c2b17bafa31b95da83a235c28109e911f78e294b12924a99114adad5bbe44cbba67fe8d2d584c9839a70d59 SHA512 aa919c8b15403b9992a772bf0296f4cae2bef39c4ded509f732a13869504f7af15cf43f26c9f401e31794c481a5e1dc4e91c18e65c31a4e159d7b9a2cb1c99ea
MISC metadata.xml 382 BLAKE2B 7c0704c5c187ce4a7972fe0372b23c5537a81a8d62fd83436d9558a61761f10764adb5a4d5f6795f0dd1fe905afa604c0be77fe1d48d291847f6ae65dc1b032c SHA512 9d0ced4df9352a81034a50d5766a01534ae8fa889985d99cc9e2a8d0889e31c6c11550677d9a5a74e2aab57c320192ce3a42708a6d23b0419ee34a6054398344
diff --git a/dev-python/tox/tox-3.27.0.ebuild b/dev-python/tox/tox-3.27.0.ebuild
new file mode 100644
index 000000000000..87ba6799d964
--- /dev/null
+++ b/dev-python/tox/tox-3.27.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+SRC_URI="
+ https://github.com/tox-dev/tox/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.1.0[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken without Internet
+ tests/unit/session/test_provision.py::test_provision_non_canonical_dep
+ tests/integration/test_provision_int.py::test_provision_interrupt_child
+
+ # expects python2 to exist
+ tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
+ )
+
+ [[ ${EPYTHON} != pypy3 ]] && EPYTEST_DESELECT+=(
+ # capfd doesn't seem to work for some non-obvious reason
+ tests/unit/test_z_cmdline.py::TestSession::test_summary_status
+ tests/unit/session/test_provision.py::test_provision_bad_requires
+
+ # TODO?
+ tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
+ )
+
+ epytest --no-network
+}