summaryrefslogtreecommitdiff
path: root/dev-python/tox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/tox
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest2
-rw-r--r--dev-python/tox/tox-3.24.5.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 30f71388d0ad..d9b50927f15b 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,3 +1,5 @@
DIST tox-3.24.4.tar.gz 306760 BLAKE2B 332c99d021bc3c25549fd95d051baaa1f0dc3aaf776928320826bb7e6bce6444fd5a993e1dbff3a4ebbde9dbb59e30d07eae4b04096294b3a186b130b8312587 SHA512 49e2cb74f119b5cc049d2a64479e56307cea1f36a5586840cca12cb8f4ce8a2ba991cc6142bef7f095a7d32b44f7513f89cce56d89deaff0e12194ceb3da6249
+DIST tox-3.24.5.tar.gz 306305 BLAKE2B a6d3338d21068d9123505a29da3beec4fd5a15c263bcaf5ba62f65a253d04e11d453bef159d06e88b2cbac9a895d786d0d9444cc16cd3de7a868eac6919b82ea SHA512 4e1ef81c978977e905edbdc00ff971eb4132b9009ce21456fcebf95d8ee2c583e04e464f1db5ca6e5454f4f1ad0353ffc9df7898f6389fe8084dc5b9726ca59b
EBUILD tox-3.24.4-r1.ebuild 2136 BLAKE2B 8cddb91c272b11e7ea543c98f06a19051c6bd3f631d371e87148336f54a016952e55fcd7afc0099ca848034584847e98d2cc0e5c97f479dd8c3dd2bf47a5865e SHA512 f068308c1208bd5e13ba3716e4c143295f4e82c4e5c28eba56f45fc12656333ed09aaf969c27073b36c206367953655d176c3c14d53f03d49da321c6c424ccbc
+EBUILD tox-3.24.5.ebuild 2143 BLAKE2B dc6ecd464b0f761226280a23d07c7494e99cc40f0d2fd3112e253d046deaca79b4ded5d3ec6da0a84a079934c702f68178a81afe0bca505281c972dc487515f7 SHA512 ae24f8aeb15c90ad997c1521c0ba32618b468b28510e327473079481272c517a9e3a9c7275ff4367ee034714162835e98c39dbc8dc2dc4da3f7d204510a4eb0b
MISC metadata.xml 382 BLAKE2B 7c0704c5c187ce4a7972fe0372b23c5537a81a8d62fd83436d9558a61761f10764adb5a4d5f6795f0dd1fe905afa604c0be77fe1d48d291847f6ae65dc1b032c SHA512 9d0ced4df9352a81034a50d5766a01534ae8fa889985d99cc9e2a8d0889e31c6c11550677d9a5a74e2aab57c320192ce3a42708a6d23b0419ee34a6054398344
diff --git a/dev-python/tox/tox-3.24.5.ebuild b/dev-python/tox/tox-3.24.5.ebuild
new file mode 100644
index 000000000000..091c40dee0ce
--- /dev/null
+++ b/dev-python/tox/tox-3.24.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+# doc disabled because of missing deps in tree
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
+# TODO: figure out how to make tests work without the package being
+# installed first.
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken without Internet
+ tests/unit/session/test_provision.py::test_provision_non_canonical_dep
+ tests/integration/test_provision_int.py::test_provision_interrupt_child
+
+ # expects python2 to exist
+ tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
+
+ # fragile and relies on checking stdout
+ tests/unit/util/test_spinner.py::test_spinner_progress
+ )
+
+ [[ ${EPYTHON} != pypy3 ]] && EPYTEST_DESELECT+=(
+ # TODO?
+ tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
+
+ # broken without tox installed first
+ # TODO: why it can't import itself?
+ tests/integration/test_parallel_interrupt.py::test_parallel_interrupt
+ )
+
+ distutils_install_for_testing --via-venv
+ epytest --no-network
+}