summaryrefslogtreecommitdiff
path: root/dev-python/tox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/tox
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest2
-rw-r--r--dev-python/tox/tox-3.25.1.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index c638bd3ffd2d..714c43859246 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,3 +1,5 @@
DIST tox-3.25.0.tar.gz 307073 BLAKE2B 2dda34fc6d6518897bdc587ca6a31b92f2add463c3bcce9df3f4e511d2588dc75265b60809195c2d78a9c1b0d08d79c32811aab1e2c01934faf40019a1882042 SHA512 9c10524c5a67b32a01cb0dd4d25cc01d0641e46ca4e0c03a4c76eb8913f6038075aeb21e647a94d6b8d99c80edb7701b1c62893ebd6a20584121fdf33b9d9010
+DIST tox-3.25.1.gh.tar.gz 307697 BLAKE2B 2c778df22388b101e6e68423636c9753f0e6faac2360184fd6b9022dc3bbb5662840cf24e7907dd4c652f6401723be3be35bcdeb0f290f9839325babf5ec776d SHA512 e0443cb72378fc18c9bc001413261d9bac2d6f89bb0ebff618a3848ffd5b02c80902cefbd90f7b0d0e3119f1df3cd22b46be23077db0ee90c03a9780ba4b248b
EBUILD tox-3.25.0.ebuild 2184 BLAKE2B 4e0f8e9386fd2cdfa09d0e2f506fde89b2e0aa3fd12f9fd787478eaf8a45c3570e6c5da73b546d18744e5b3231cb8be96dfb29ecb93bdca26257cbe70757f95c SHA512 0529e0b5ce6819e82e2c4733234ab9a459449843e45d3296a3e0836bd795f279aa8bf109a65b7a673f9370b6b312b42247ab6fab886e8e225ea218e89e7849bc
+EBUILD tox-3.25.1.ebuild 1872 BLAKE2B 7876a07bc579ea6f6e0e36ed0ebbd6e71fa04334c99b7d7a0a961176b432d7d16f3620ef2689cedc91a3b97c03f4576c8cf471e47c3d272c5dcd1a11bd21ad2c SHA512 7363bd617c4e9c8f92b935b1fec3ccacafff89602ab5e622271f94c4e94bfae3c49affbbd7699dca057c89593d1baad76e04c0a5e3c76bcd50825394ee8a2e4f
MISC metadata.xml 382 BLAKE2B 7c0704c5c187ce4a7972fe0372b23c5537a81a8d62fd83436d9558a61761f10764adb5a4d5f6795f0dd1fe905afa604c0be77fe1d48d291847f6ae65dc1b032c SHA512 9d0ced4df9352a81034a50d5766a01534ae8fa889985d99cc9e2a8d0889e31c6c11550677d9a5a74e2aab57c320192ce3a42708a6d23b0419ee34a6054398344
diff --git a/dev-python/tox/tox-3.25.1.ebuild b/dev-python/tox/tox-3.25.1.ebuild
new file mode 100644
index 000000000000..3bbaa66f67b8
--- /dev/null
+++ b/dev-python/tox/tox-3.25.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+SRC_URI="
+ https://github.com/tox-dev/tox/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken without Internet
+ tests/unit/session/test_provision.py::test_provision_non_canonical_dep
+ tests/integration/test_provision_int.py::test_provision_interrupt_child
+
+ # expects python2 to exist
+ tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
+ )
+
+ [[ ${EPYTHON} != pypy3 ]] && EPYTEST_DESELECT+=(
+ # capfd doesn't seem to work for some non-obvious reason
+ tests/unit/test_z_cmdline.py::TestSession::test_summary_status
+ tests/unit/session/test_provision.py::test_provision_bad_requires
+
+ # TODO?
+ tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
+ )
+
+ epytest --no-network
+}