summaryrefslogtreecommitdiff
path: root/dev-python/tox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/tox
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest2
-rw-r--r--dev-python/tox/tox-3.25.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index bb7020162934..140d2f97b4d8 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,3 +1,5 @@
DIST tox-3.24.5.tar.gz 306305 BLAKE2B a6d3338d21068d9123505a29da3beec4fd5a15c263bcaf5ba62f65a253d04e11d453bef159d06e88b2cbac9a895d786d0d9444cc16cd3de7a868eac6919b82ea SHA512 4e1ef81c978977e905edbdc00ff971eb4132b9009ce21456fcebf95d8ee2c583e04e464f1db5ca6e5454f4f1ad0353ffc9df7898f6389fe8084dc5b9726ca59b
+DIST tox-3.25.0.tar.gz 307073 BLAKE2B 2dda34fc6d6518897bdc587ca6a31b92f2add463c3bcce9df3f4e511d2588dc75265b60809195c2d78a9c1b0d08d79c32811aab1e2c01934faf40019a1882042 SHA512 9c10524c5a67b32a01cb0dd4d25cc01d0641e46ca4e0c03a4c76eb8913f6038075aeb21e647a94d6b8d99c80edb7701b1c62893ebd6a20584121fdf33b9d9010
EBUILD tox-3.24.5.ebuild 2135 BLAKE2B a84e8f10804ae79620b42d7c41a9653234e84a4713dde8d298326f6c728e86e9d541c9561b8888ea00b3af411c186abc735fabef2980e9a3fd515aef20a6fa82 SHA512 7938df52c3d4f4b20b05db6ee4c585d3d5bfb5f946a3fda7e02e134d259e937c0a00dd78d1636cab5abdf23ebe855fe9160af8b47055e2bfbd4d6e80b6a42991
+EBUILD tox-3.25.0.ebuild 2192 BLAKE2B 4f1ad22c5cb015e59eda3047c751a7780d3935b271f2c68c9810008ab4e6722a700df4611029f76ecae10dd97c5b06528a4627ec02df9220ea6381a3d7dcbf75 SHA512 e817ad9c8eac18eded5ad4c4b44bbe195767ab7ab3c19f509636a808ba1fc182cd3be1904e8e88adf1f336f9ef1c0db747f8100306bd2a77292af8addd6fb171
MISC metadata.xml 382 BLAKE2B 7c0704c5c187ce4a7972fe0372b23c5537a81a8d62fd83436d9558a61761f10764adb5a4d5f6795f0dd1fe905afa604c0be77fe1d48d291847f6ae65dc1b032c SHA512 9d0ced4df9352a81034a50d5766a01534ae8fa889985d99cc9e2a8d0889e31c6c11550677d9a5a74e2aab57c320192ce3a42708a6d23b0419ee34a6054398344
diff --git a/dev-python/tox/tox-3.25.0.ebuild b/dev-python/tox/tox-3.25.0.ebuild
new file mode 100644
index 000000000000..71dda6586496
--- /dev/null
+++ b/dev-python/tox/tox-3.25.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+# doc disabled because of missing deps in tree
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken without Internet
+ tests/unit/session/test_provision.py::test_provision_non_canonical_dep
+ tests/integration/test_provision_int.py::test_provision_interrupt_child
+
+ # expects python2 to exist
+ tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
+
+ # fragile and relies on checking stdout
+ tests/unit/util/test_spinner.py::test_spinner_progress
+
+ # TODO
+ tests/unit/test_z_cmdline.py::TestSession::test_summary_status
+ tests/unit/session/test_provision.py::test_provision_bad_requires
+ )
+
+ [[ ${EPYTHON} != pypy3 ]] && EPYTEST_DESELECT+=(
+ # TODO?
+ tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
+
+ # broken without tox installed first
+ # TODO: why it can't import itself?
+ tests/integration/test_parallel_interrupt.py::test_parallel_interrupt
+ )
+
+ epytest --no-network
+}