summaryrefslogtreecommitdiff
path: root/dev-python/tornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-12 06:07:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-12 06:07:09 +0100
commit6766ae9a4205bc53227127a1dd518ea601246afe (patch)
tree0717a1249b6c0340842b8f5cf78a3774ef985043 /dev-python/tornado
parent4658e9ebb16790a76f119b3c702097e068bd60f3 (diff)
gentoo auto-resync : 12:08:2023 - 06:07:08
Diffstat (limited to 'dev-python/tornado')
-rw-r--r--dev-python/tornado/Manifest1
-rw-r--r--dev-python/tornado/tornado-6.3.2.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/tornado/Manifest b/dev-python/tornado/Manifest
index 87108073710c..054df5e366c4 100644
--- a/dev-python/tornado/Manifest
+++ b/dev-python/tornado/Manifest
@@ -3,6 +3,5 @@ AUX tornado-6.3.2-test-timeout-increase.patch 521 BLAKE2B 9d3b5d8a380178f84146e7
DIST tornado-6.3.2.tar.gz 508776 BLAKE2B 10cea881365ab72290ac9bc240dc7fa4e77511be1aa9d005e84fff1c494888d204935f5bf5101d102cc6e8f0995d41c0cc257e372d740f2aa47dc904032c434d SHA512 cd4be43672dcf0814536ad1b2b1dde045f25494a9f70facf0dbae5d3a71b112d0dbca235916948982922975d0d4c58efff880c0b432db382f58f25d65ef18c92
DIST tornado-6.3.3.tar.gz 509872 BLAKE2B 575928b932a912515730b23ab712d6107b27ccb37c703be722768442093d47623e27ed31f60816c4031cd04354182796275619f27896d970e350dbb51a341b0a SHA512 3d4b0f933f09b8f8d5de5f93662de73d97a0ed98f5b56e0810d803d537092c74e89315dc9aaa0af85f91e18eca64cf429f6f73bce29523ce56738398fa24a597
EBUILD tornado-6.3.2-r1.ebuild 1840 BLAKE2B 7456df8ffca863af6670f8cfa91a6fab93ca19bb89beb2fe5da3c49b1a5a28354ecf3da7a3d7c00a71b63a4e3756c34a621bd804147c39b9ad1291ecc2e100a5 SHA512 b997cafd4da5fe061da2a8eb122894ca20440b192b3c8f77ccf5e1042b16b66355777b217589fcc74a5c6aa6ead4c85acba0525028bd2e269daa7b513b6fc6cb
-EBUILD tornado-6.3.2.ebuild 1626 BLAKE2B e07c18f1cd4368633cbad79c075c3e42b6863e694529dddfa2978ff5357bb170b66f36acea196b68e1538bc02261b42ee6e291787e4b39f63330a9a400ed1f91 SHA512 65c1d9dfce9575efec188da4ca231835cc0dc17885b997e9b216e556225c03e9f3886c7a1dc03ea87c872f47d7145fa02ddcae89d263d9cdbe006cf2e543ddc1
EBUILD tornado-6.3.3.ebuild 1848 BLAKE2B f56627af6eaee0678d61dfef1132ce5e3af1ea8dbf6a61d08fd41a6c7577bb3424b42a8c73fe607c4704c629566b1ed92ab1ce566f0be49480c09cf811ecc85f SHA512 308571e7de81cc4bc9cfe854f0ed92dc9262f7b5db12d1c646690c80a302479808a0a6829bd707b217f22a8cc06262ad7d22596cdab95a7412f673f2612cbdfd
MISC metadata.xml 381 BLAKE2B 96d5942b11b6364eeac2248f6e92a9e7a54094ba2b6e9ef966be4143e1fa01fa0c417027d33a71c51bb094b905b9ff79e05107e1a9debb4b1ef932ba11fd8565 SHA512 cd4db13e0c6a9cf8b3c788c53dc5ecd0dce2cf783e7b2d67dba71299d1c6a3d1dd2c2a76c0d69816ab0da4ca23f831613323c55864fd858690c605da5426bf60
diff --git a/dev-python/tornado/tornado-6.3.2.ebuild b/dev-python/tornado/tornado-6.3.2.ebuild
deleted file mode 100644
index 4f1f73583d5e..000000000000
--- a/dev-python/tornado/tornado-6.3.2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python web framework and asynchronous networking library"
-HOMEPAGE="
- https://www.tornadoweb.org/
- https://github.com/tornadoweb/tornado/
- https://pypi.org/project/tornado/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- $(python_gen_cond_dep '
- >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.3.2-test-timeout-increase.patch
- "${FILESDIR}"/${PN}-6.3.2-ignore-deprecationwarning.patch
-)
-
-src_prepare() {
- # network-sandbox? ipv6?
- sed -i -e 's:test_localhost:_&:' \
- tornado/test/netutil_test.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x ASYNC_TEST_TIMEOUT=60
- # Avoid time-sensitive tests
- # https://github.com/tornadoweb/tornado/blob/10974e6ebee80a26a2a65bb9bd715cf858fafde5/tornado/test/util.py#L19
- local -x TRAVIS=1
- local -x NO_NETWORK=1
-
- cd "${T}" || die
- "${EPYTHON}" -m tornado.test.runtests --verbose ||
- die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r demos/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}