summaryrefslogtreecommitdiff
path: root/dev-python/tornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-29 10:51:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-29 10:51:05 +0000
commit65277f763adcb68cea58abf75cd35eab450a0d15 (patch)
treeecbede5e2e057a3fcd5c996882354ad5f400c119 /dev-python/tornado
parentb20b0e862d577cc2f56ed09f5f833a80fd839d38 (diff)
gentoo auto-resync : 29:11:2023 - 10:51:05
Diffstat (limited to 'dev-python/tornado')
-rw-r--r--dev-python/tornado/Manifest2
-rw-r--r--dev-python/tornado/tornado-6.4.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/tornado/Manifest b/dev-python/tornado/Manifest
index 23751a9e9a34..32754c03b8ab 100644
--- a/dev-python/tornado/Manifest
+++ b/dev-python/tornado/Manifest
@@ -1,5 +1,7 @@
AUX tornado-6.3.2-ignore-deprecationwarning.patch 656 BLAKE2B a64b3b5f021f4e1939c69f20fe93ef61eb64666b083773c1fa189af03d0964b8832a97d49ce18924f9e1202f26bb85b76d182f2baaa8265d0e1a2decbd12efef SHA512 5cd0258db519ec2a02a9988160a345c94ffb2abae92a78fb8e9d3eb6017bac8ecb86f4ef0e3eedb5ea561344213850e2b342a1f6517c909a3c6a0224606f2afd
AUX tornado-6.3.2-test-timeout-increase.patch 521 BLAKE2B 9d3b5d8a380178f84146e7909a6557c28c48df775abb96afadbe4a06a7b565d5c32f39359060fd45028120c8952238f95fca3348e225096784e806864cfd2b7a SHA512 00a964cd75224195e8de77bc7137c087c6f4128734a9c55505ef4d88d512deb0325df56e3da4c8fefac10915613e1dc244c9107123a22bc9f124fa515fae9f4a
DIST tornado-6.3.3.tar.gz 509872 BLAKE2B 575928b932a912515730b23ab712d6107b27ccb37c703be722768442093d47623e27ed31f60816c4031cd04354182796275619f27896d970e350dbb51a341b0a SHA512 3d4b0f933f09b8f8d5de5f93662de73d97a0ed98f5b56e0810d803d537092c74e89315dc9aaa0af85f91e18eca64cf429f6f73bce29523ce56738398fa24a597
+DIST tornado-6.4.tar.gz 498845 BLAKE2B ebcdcfa93490107addfe69f722e2d85058a92fc366b09a4794a4d6e0a93040ef9791095a5a94d21937d4e88dea09521644cf92d0f2c7e98238dc58e6b864a009 SHA512 c063509d4c385e410c63cccdc1e9c66aa2bb739473667ede56cb801b7379b910c8059dec831d609109f3076222b588b257afd960dffa422d7a872867dcdda7c7
EBUILD tornado-6.3.3.ebuild 1853 BLAKE2B 9f73c3e342e9ba8da10bd6b3d94eb89805076b61cc9b5380cdf4c94205aae642a709d8bf58bff531842436217726ccced5335c6b5184ecdb3de1c9289179bd68 SHA512 d1ab45a70293e47574af533745ac2f78eb74a2bdd209a8f748e9be877e6d532ea660dc42caa3138db8e32ca850c74c76ad4a1e6357ef1ad1e8c1ab09b4585f36
+EBUILD tornado-6.4.ebuild 1468 BLAKE2B 78f47d740c817fc9caf321bd3089662985a77681a5316b1e40864d926772f6179b50a31df9a3c757e836f39f520bbf46c7b864668ade6f01ae3d4be47dec81f3 SHA512 66ff99a9175f38df2f655bb6be8527d1c6ea548a0e4a143260590add74e1be42bd344423354dedae91cb6e3fe79f90299b2ae5e74d9cfd1e51f179326d6c44ff
MISC metadata.xml 381 BLAKE2B 96d5942b11b6364eeac2248f6e92a9e7a54094ba2b6e9ef966be4143e1fa01fa0c417027d33a71c51bb094b905b9ff79e05107e1a9debb4b1ef932ba11fd8565 SHA512 cd4db13e0c6a9cf8b3c788c53dc5ecd0dce2cf783e7b2d67dba71299d1c6a3d1dd2c2a76c0d69816ab0da4ca23f831613323c55864fd858690c605da5426bf60
diff --git a/dev-python/tornado/tornado-6.4.ebuild b/dev-python/tornado/tornado-6.4.ebuild
new file mode 100644
index 000000000000..f86398464b4b
--- /dev/null
+++ b/dev-python/tornado/tornado-6.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="
+ https://www.tornadoweb.org/
+ https://github.com/tornadoweb/tornado/
+ https://pypi.org/project/tornado/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.2-test-timeout-increase.patch
+ "${FILESDIR}"/${PN}-6.3.2-ignore-deprecationwarning.patch
+)
+
+src_prepare() {
+ # network-sandbox? ipv6?
+ sed -i -e 's:test_localhost:_&:' \
+ tornado/test/netutil_test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x ASYNC_TEST_TIMEOUT=60
+ # Avoid time-sensitive tests
+ # https://github.com/tornadoweb/tornado/blob/10974e6ebee80a26a2a65bb9bd715cf858fafde5/tornado/test/util.py#L19
+ local -x TRAVIS=1
+ local -x NO_NETWORK=1
+
+ cd "${T}" || die
+ "${EPYTHON}" -m tornado.test.runtests --verbose ||
+ die "tests failed under ${EPYTHON}"
+}