summaryrefslogtreecommitdiff
path: root/dev-python/tornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-26 15:08:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-26 15:08:09 +0100
commit2ad011cd42b40aebf90105be4521fb1727266d1d (patch)
treed9dc4f7c1665a6ba336ba8a9fa773f1292895b76 /dev-python/tornado
parente0dcb1c4ea48292b379fadd53f55f1df42cf7eab (diff)
gentoo auto-resync : 26:09:2022 - 15:08:08
Diffstat (limited to 'dev-python/tornado')
-rw-r--r--dev-python/tornado/Manifest3
-rw-r--r--dev-python/tornado/metadata.xml12
-rw-r--r--dev-python/tornado/tornado-6.2.ebuild68
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/tornado/Manifest b/dev-python/tornado/Manifest
new file mode 100644
index 000000000000..3e6290070b03
--- /dev/null
+++ b/dev-python/tornado/Manifest
@@ -0,0 +1,3 @@
+DIST tornado-6.2.tar.gz 504849 BLAKE2B 18fee464e043e20dcdd5677bc3a72949140a64ce353e09a21242fcade6d8b668517553c649d65e892d9c3fabacea96903d4e42b70676a62759900abc8f4a202f SHA512 157cbeee21bef29ac68b319329e7fc57db4c68dbb5a245e2171b7a28427ebbfe16b745e3bdbdec5912caae5eaa60c3cbbf8830c9c76fec5ffdf025e234468517
+EBUILD tornado-6.2.ebuild 1729 BLAKE2B e03b29269da29e83de6e533fb4f2257855bb1f1d93ab8641a45c023bca7d95b4faed126e5ea8c0221e58448dbcb575a051002e56817fb7368ee4a6bde80beb99 SHA512 3894197e9d2baad1c80bb863e04c47d7d92d2c7d36e9218d8bd48ea89ad19b021265fa5ef6ec775b78b102b80e70c5cbc69d2f648a4c2654e53020e2eb982c07
+MISC metadata.xml 381 BLAKE2B 96d5942b11b6364eeac2248f6e92a9e7a54094ba2b6e9ef966be4143e1fa01fa0c417027d33a71c51bb094b905b9ff79e05107e1a9debb4b1ef932ba11fd8565 SHA512 cd4db13e0c6a9cf8b3c788c53dc5ecd0dce2cf783e7b2d67dba71299d1c6a3d1dd2c2a76c0d69816ab0da4ca23f831613323c55864fd858690c605da5426bf60
diff --git a/dev-python/tornado/metadata.xml b/dev-python/tornado/metadata.xml
new file mode 100644
index 000000000000..990b39b886fd
--- /dev/null
+++ b/dev-python/tornado/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">tornado</remote-id>
+ <remote-id type="github">tornadoweb/tornado</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tornado/tornado-6.2.ebuild b/dev-python/tornado/tornado-6.2.ebuild
new file mode 100644
index 000000000000..eb50d15d6c03
--- /dev/null
+++ b/dev-python/tornado/tornado-6.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="
+ https://www.tornadoweb.org/
+ https://github.com/tornadoweb/tornado/
+ https://pypi.org/project/tornado/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinxcontrib-asyncio
+
+src_prepare() {
+ # Disable deprecation-warnings-as-errors because tornado has a lot of stuff deprecated in 3.10
+ sed 's/warnings.filterwarnings("error", category=DeprecationWarning, module=r"tornado\\..*")//' \
+ -i tornado/test/runtests.py || die
+ # broken upstream
+ sed -i -e 's:test_multi_line_headers:_&:' \
+ tornado/test/httpclient_test.py || die
+ # network-sandbox? ipv6?
+ sed -i -e 's:test_localhost:_&:' \
+ tornado/test/netutil_test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x ASYNC_TEST_TIMEOUT=60
+ cd "${T}" || die
+ "${EPYTHON}" -m tornado.test.runtests --verbose ||
+ die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}