summaryrefslogtreecommitdiff
path: root/dev-python/toposort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/toposort
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/toposort')
-rw-r--r--dev-python/toposort/Manifest3
-rw-r--r--dev-python/toposort/metadata.xml17
-rw-r--r--dev-python/toposort/toposort-1.6.ebuild18
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/toposort/Manifest b/dev-python/toposort/Manifest
new file mode 100644
index 000000000000..1fb4c316588f
--- /dev/null
+++ b/dev-python/toposort/Manifest
@@ -0,0 +1,3 @@
+DIST toposort-1.6.tar.gz 11690 BLAKE2B a9a57fd182a3324d43112c3f84a20039f032d99bf2c35c6678a6a08c23b123f18610f460529dd39c769b935d98270a25ded2f1a483e4e6f06d3ccc501b340cb8 SHA512 8dc30b5d5a6f476756520236bc93840243690779783ec8f0b5ef0f72c64d774177b25d10d2e024cda968f81352abbc4f89f3069760fc3a86bd5ee387e7951928
+EBUILD toposort-1.6.ebuild 413 BLAKE2B f9f0958847ba209b9d07593b17b8f0d802fb2c1d95da6bf3465b782015c8bcab0ec6bcb11f1397c844e941c3f8dc8d51b6929d1bf31de95655cbf7b66ed7ffbc SHA512 56af58526ebaed5cd44ee0e1cc50dd1e09df469699a2c0277d0bc328dc9a5caaf9fa71ba6dea7856f36e9cca09fb0f6027154d63134a0e170ed7ed9978c250b1
+MISC metadata.xml 551 BLAKE2B a8d8483b1a725bfdbb0c5ed3688bcd15093f0a51fc56cf8cdf30a836c98818a5ca5e7732e8045bd9cba76dde69aa05f2be45f9765f48b2177e9e8aa67a726880 SHA512 f2b0b6fb5f95c0f946149c1d959affa926452acfc21e46dda6f34448c8799df4fb8ddefc3856cb09420bed26f41c945ff309514bdc3fe87c77465784f3c57cf5
diff --git a/dev-python/toposort/metadata.xml b/dev-python/toposort/metadata.xml
new file mode 100644
index 000000000000..d8231c836080
--- /dev/null
+++ b/dev-python/toposort/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>torokhov-s-a@yandex.ru</email>
+ <name>Sergey Torokhov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="gitlab">ericvsmith/toposort</remote-id>
+ <remote-id type="pypi">toposort</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/toposort/toposort-1.6.ebuild b/dev-python/toposort/toposort-1.6.ebuild
new file mode 100644
index 000000000000..ae4eca4b79e4
--- /dev/null
+++ b/dev-python/toposort/toposort-1.6.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="https://gitlab.com/ericvsmith/toposort"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests setup.py