summaryrefslogtreecommitdiff
path: root/dev-python/tomlkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-27 11:40:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-27 11:40:34 +0000
commite4be1c42deab59fa5baee33fa9b1c48e5c4c6dc7 (patch)
treeb4534a27fdf6bf08f5703b897a4684732e78151a /dev-python/tomlkit
parent0a5376618896a890256bc26687f4cd8bbe302df6 (diff)
gentoo auto-resync : 27:02:2024 - 11:40:34
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest2
-rw-r--r--dev-python/tomlkit/tomlkit-0.12.4.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 91ba9c4e73e5..c887f48d5a4a 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,3 +1,5 @@
DIST tomlkit-0.12.3.tar.gz 190967 BLAKE2B 82205c8e012d4584c60ce8d53a995a01fccd50e35330b8aaecd84dd348b79be1ec7cd9bbaf84dbdbcd904102b7dc4216551298657553606d4da8457f565e8945 SHA512 f89b1fdcbefcd511bbc5e22a1cc57d8c4593fc1353e901de31c69ac99ed3c685f042d71205c747bd5d20df246dd19b5402393df81231f12d18414d85c0a0000c
+DIST tomlkit-0.12.4.tar.gz 191162 BLAKE2B 3a5f8f01c7965a6d445fa96d0253d0dad55414bf9cae875fe9d9bc670d5b0a20a76fbf655695396ea188cddcea7ad034a38eed05d85f48c47301a3f23a9c7ded SHA512 b6b1cbb954202a256411388eea46852964bbdd02026086a42eab9107c55b961718398ec504f0289560894e9b46cf1c2f4b7e943267454509f6212e899e161d05
EBUILD tomlkit-0.12.3.ebuild 971 BLAKE2B 75e6cfba124a94757c2e10ca5ea406535393020a86d114771abc29569061954af6430963c94b4fec11f312d7ca5143ca5b4d3ee0ad2e1a47af41370473b99c11 SHA512 d8ed481c1fd001814da2a3ea0a400d4e9fddf2d7aa3ddb7cdb45410e90b6b793ba98a365296a9b5b67f3bc7f0dd0c6e2fa466d8d553ea623c958699a4af1f094
+EBUILD tomlkit-0.12.4.ebuild 979 BLAKE2B 8172ccd3cc70d7e7a7c91e90bcc4458e824f0bdf7c0aaf51cd13a01055696620a40bdac681abfe145b7e79470004b5be7df30ad12b0ee271fd55c07ccc1c641f SHA512 7ded503e0f8947f1f18f9f4ada5f3f4965c1dcc4440cea7fdfdc19eb9b2110311c28693a5b485cd61bfdc9ddbc1104e1e4779819893e0bab9e1ef2923282fed5
MISC metadata.xml 525 BLAKE2B 663169c851817eb7368c49d678119f1f2dfebe642325d3dbc59498f60b452710a257ca5cd5173a4fc8391d33038cce079b3fba112ad7e9c0caf0c1872ee43f13 SHA512 5a6cf412fc06854557d001ae4a6f654b36d351c8c0b4bc08c1a7c40f49d8dceba931598f5eed6c75e1d7797570fcf8fb7799f5f035931f80d05b1e9bd0d258c0
diff --git a/dev-python/tomlkit/tomlkit-0.12.4.ebuild b/dev-python/tomlkit/tomlkit-0.12.4.ebuild
new file mode 100644
index 000000000000..909ac0927d76
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.12.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "poetry' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "tomlkit"
+ version = "${PV}"
+ description = "Style preserving TOML library"
+ EOF
+}