summaryrefslogtreecommitdiff
path: root/dev-python/tomlkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-15 10:39:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-15 10:39:42 +0000
commit55cd3ff92ff96fafc75066838cfc2af06df3a296 (patch)
tree80062e679cfed7bd24918ebef931ffbe5ef3e513 /dev-python/tomlkit
parent5038813910e661a4943401a80a3725aca040c01c (diff)
gentoo auto-resync : 15:11:2023 - 10:39:42
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest2
-rw-r--r--dev-python/tomlkit/tomlkit-0.12.3.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index a203396e6fe5..c5b0983c17ac 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,5 +1,7 @@
DIST tomlkit-0.12.1.tar.gz 190535 BLAKE2B 461891b5f5dad93488d466560439e19865fcb315792418e24483c96f4c9387c67d9c322bcc4ba842861109ff3297e064cd38737769d97ad1f99dadd9c11f7b33 SHA512 1f82023cbb8168f847bfa0211ee5c4d6870973ee1f51f4b60deb34ae6e0e930fe299c939b6c157811d16a73c68225a468e8312ca2731e1bbdcc5541fde2e2360
DIST tomlkit-0.12.2.tar.gz 190725 BLAKE2B f168f42e99cbd8ed5d958ec471fc824d3a89f72d0d68b8881c5c935d888f1b0464e6ca34e65741a9de9d98c093a1e23073378006693bbd6c85870f368291760a SHA512 c36405e95ab42e1e728b4344dd71d183c2e8c174b3524d3337af2456e141f5a54fed82c1f613d5493efef50170f2985f74b1e5859790e865379fab7f90f03c65
+DIST tomlkit-0.12.3.tar.gz 190967 BLAKE2B 82205c8e012d4584c60ce8d53a995a01fccd50e35330b8aaecd84dd348b79be1ec7cd9bbaf84dbdbcd904102b7dc4216551298657553606d4da8457f565e8945 SHA512 f89b1fdcbefcd511bbc5e22a1cc57d8c4593fc1353e901de31c69ac99ed3c685f042d71205c747bd5d20df246dd19b5402393df81231f12d18414d85c0a0000c
EBUILD tomlkit-0.12.1.ebuild 971 BLAKE2B 75e6cfba124a94757c2e10ca5ea406535393020a86d114771abc29569061954af6430963c94b4fec11f312d7ca5143ca5b4d3ee0ad2e1a47af41370473b99c11 SHA512 d8ed481c1fd001814da2a3ea0a400d4e9fddf2d7aa3ddb7cdb45410e90b6b793ba98a365296a9b5b67f3bc7f0dd0c6e2fa466d8d553ea623c958699a4af1f094
EBUILD tomlkit-0.12.2.ebuild 979 BLAKE2B 8bfd98336a91660b29f03e6d2d8fda98ef6085ec4c4994d5712c96b464a53d3e94ec505cb83df6eae9213e404e595ae0335de23dbd79b6d2e33f04c1e4875cf5 SHA512 53d1e9d302fc479da61aefedb6991b15ddf5f1545ad87bb7d0d6391825fbd644a44fda1bf8c902c410b03c1ac96f070251b0e89074c8fbed1c2451ea445f281c
+EBUILD tomlkit-0.12.3.ebuild 979 BLAKE2B 8bfd98336a91660b29f03e6d2d8fda98ef6085ec4c4994d5712c96b464a53d3e94ec505cb83df6eae9213e404e595ae0335de23dbd79b6d2e33f04c1e4875cf5 SHA512 53d1e9d302fc479da61aefedb6991b15ddf5f1545ad87bb7d0d6391825fbd644a44fda1bf8c902c410b03c1ac96f070251b0e89074c8fbed1c2451ea445f281c
MISC metadata.xml 525 BLAKE2B 663169c851817eb7368c49d678119f1f2dfebe642325d3dbc59498f60b452710a257ca5cd5173a4fc8391d33038cce079b3fba112ad7e9c0caf0c1872ee43f13 SHA512 5a6cf412fc06854557d001ae4a6f654b36d351c8c0b4bc08c1a7c40f49d8dceba931598f5eed6c75e1d7797570fcf8fb7799f5f035931f80d05b1e9bd0d258c0
diff --git a/dev-python/tomlkit/tomlkit-0.12.3.ebuild b/dev-python/tomlkit/tomlkit-0.12.3.ebuild
new file mode 100644
index 000000000000..b8055655dd0a
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.12.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "poetry' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "tomlkit"
+ version = "${PV}"
+ description = "Style preserving TOML library"
+ EOF
+}