summaryrefslogtreecommitdiff
path: root/dev-python/tomlkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-15 12:22:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-15 12:22:30 +0100
commit3ad1879f00b279af69d6b9cd3ef97a2a7496d734 (patch)
tree497e5c46d6f6695b96866bc46abe1a2470a880b5 /dev-python/tomlkit
parent792e307954fd3b5b12c968741d76ea7cfe5206e4 (diff)
gentoo auto-resync : 15:08:2024 - 12:22:30
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest2
-rw-r--r--dev-python/tomlkit/tomlkit-0.13.2.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index b90e3a69a814..a6e9421d4f40 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,5 +1,7 @@
DIST tomlkit-0.13.0.tar.gz 191792 BLAKE2B f5f865b49f9850281d01de2c2ba9c2d8685a10a5cd0f17c475d120978472485a5bd607dc4b283221eab69fc6e214259feafdbe85c8237fe9c80b49007523bb69 SHA512 46c5a771ff401e0b300dbd13708d78b63415653b87eb649898bf0bd58cedeb110622ff2f0ade0ad1cd517610229ba0f59b4d520cf2fa1eea6522ea0bc042317e
DIST tomlkit-0.13.1.tar.gz 192625 BLAKE2B 1f1ebc96819eb742429d7d8a71b8f3aecdd964f0700052bb2f71ede866c5f97b25745bf95898d7b1005c881d3fdbb36c4cb872126a3be8192cb9c859eb153fbe SHA512 32023020de48d0eacd0ce886870b9a53defdb403b396eb03d0c026c221460eeede1f018586ae141d690722485446be0215582182809c590d1af9825e840b58ad
+DIST tomlkit-0.13.2.tar.gz 192885 BLAKE2B c95d24e0ec61cb90dfdd3fe7a07f8187fdfdee1b60d6d3e5a1af08e6d319e24c2447107cd3e49455a3f1cd29a50bde2e09f3a57708ce7349d1e9bd6957e46c9d SHA512 65b45468de25a6b9f22c3fe3468301902e1e439de580e74f15f5a24985546a4bfe47642b6014a25590eb176fedbe468828d7bc84c9c3b65ab418c071f0902957
EBUILD tomlkit-0.13.0.ebuild 1046 BLAKE2B 6b5bb8be3c8fe0b8acf6d1920a6a3f4c789096f260c1ec5b43b5413529d04efcc9d199d3116014376306e61b15ddf3ea61825ec224692245c1be84bbcffd2cbb SHA512 3d45e510ca0f796c7ddee13cda4be2cf2d5edc2581cb48504117a6bc2d48e8ace8538c99e389f491371d954bec80b31891d80dab2a324c0a760e0fb4d567586c
EBUILD tomlkit-0.13.1.ebuild 1054 BLAKE2B ff9edeb9b6ac424f11db0f96820af6b62dd605d9e1a0051c0763b007d779621b4b35336733e696c5d19e0b079b99e41a92e7272a0dc571200b2720470a4c7d21 SHA512 96d7aca710467357b6217936b4bdb854b02379713e2cc9cf15fcb2cc06c132f27631cc8c7a01d1c1d0ba3c991573e74c84ec85d2feb474ff0a66f5e36638eed2
+EBUILD tomlkit-0.13.2.ebuild 1054 BLAKE2B ff9edeb9b6ac424f11db0f96820af6b62dd605d9e1a0051c0763b007d779621b4b35336733e696c5d19e0b079b99e41a92e7272a0dc571200b2720470a4c7d21 SHA512 96d7aca710467357b6217936b4bdb854b02379713e2cc9cf15fcb2cc06c132f27631cc8c7a01d1c1d0ba3c991573e74c84ec85d2feb474ff0a66f5e36638eed2
MISC metadata.xml 529 BLAKE2B 313663d81102b8124a7ebbe11e18003c4714e26daf97ce180c1690b147d750bebfe23af9d894f87ae218148cfb59c3405b25b1736d65fef16bcff4466e026e76 SHA512 f2bab5270eb7346e5de28ed96fb51ded6956ed57724d2ffba6f94b288699ef8107b78155c7c350321e11955c05967d6320444005725c3beedb711cc585f8fa41
diff --git a/dev-python/tomlkit/tomlkit-0.13.2.ebuild b/dev-python/tomlkit/tomlkit-0.13.2.ebuild
new file mode 100644
index 000000000000..32ec3c8a18ae
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.13.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/python-poetry/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "poetry' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "tomlkit"
+ version = "${PV}"
+ description = "Style preserving TOML library"
+ EOF
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}