summaryrefslogtreecommitdiff
path: root/dev-python/tomli-w
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/tomli-w
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/tomli-w')
-rw-r--r--dev-python/tomli-w/Manifest2
-rw-r--r--dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild17
2 files changed, 13 insertions, 6 deletions
diff --git a/dev-python/tomli-w/Manifest b/dev-python/tomli-w/Manifest
index 604cbd555825..47def248fe8b 100644
--- a/dev-python/tomli-w/Manifest
+++ b/dev-python/tomli-w/Manifest
@@ -1,3 +1,3 @@
DIST tomli-w-1.0.0.gh.tar.gz 63862 BLAKE2B f10dc80ce76edafd78fc66dd488a35bb0e1d8bf31d0cc0e3b970be19f5cda40d992fafd46d1361b55df4a787d48f38260ac2be77def7ac938f62144e4c810897 SHA512 406f81e4e8151e55e8367031b5880f51de41016711238a114c82962012de4b90d5e465c503a8979d565d07843fbc4804a53c29848e4f6e5f20f9ec5dc5ce536a
-EBUILD tomli-w-1.0.0-r1.ebuild 602 BLAKE2B a516181fa29185f55b58b0309979f7e55660d9f4cbfbafa5b38379ad61868b02c8bcbeb792f2c099079d0ccb2b3e82d1d859db664ceb364be8cc2ec79cdc3b95 SHA512 e9988ce0790f3277e87c06e189ae11664c03c3f365e8f147c4d6aa061dbf9e574d88d4b4e3d564a5e01d28fcda99a5a6033bd1f3189babbf67886f8b41bc26bb
+EBUILD tomli-w-1.0.0-r1.ebuild 652 BLAKE2B 8373d02a639269a489e927c8d15ea7e01f83e9511862d4cc4a65ef7faa7efaa8785aa509c55ea0d6ec8d16cc76f131578a9957d8d16f12d5f0264f818b404aab SHA512 5f24061d09376d91484734c52e243d033e644763e7c8125a9ad2a99dcb63baf2951cc6bd7780edbc23a1c7a5a71a3988ed3976d0fdaa2b0e74c8ecf34224f5cd
MISC metadata.xml 367 BLAKE2B e088ed9141a1b4ad1506ce67b48a6666c9bf9c84e761906a95112a81d4cd9b98ebd0db756cedf007c3f50e39321697f8fc91ef6e49e668ca794ff78e8b03080a SHA512 784aff95fbc1cb65e4eed20258499260400fe31feb96acc6fbde00353d629595d8e23ecc6b550bf608294fc882c42063d0a23699defddb6699df59add7e8acaf
diff --git a/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild b/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild
index 63451645b910..2d68495a7fe3 100644
--- a/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild
+++ b/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild
@@ -4,23 +4,30 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="A lil' TOML writer"
HOMEPAGE="
https://pypi.org/project/tomli-w/
- https://github.com/hukkin/tomli-w/"
+ https://github.com/hukkin/tomli-w/
+"
SRC_URI="
https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
- test? ( dev-python/tomli[${PYTHON_USEDEP}] )"
+ test? ( dev-python/tomli[${PYTHON_USEDEP}] )
+"
distutils_enable_tests pytest
+
+python_test() {
+ epytest tests
+}