summaryrefslogtreecommitdiff
path: root/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild')
-rw-r--r--dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild b/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..d45b2248a1e7
--- /dev/null
+++ b/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML writer"
+HOMEPAGE="
+ https://pypi.org/project/tomli-w/
+ https://github.com/hukkin/tomli-w/"
+SRC_URI="
+ https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? ( dev-python/tomli[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest