summaryrefslogtreecommitdiff
path: root/dev-python/toml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/toml
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/toml')
-rw-r--r--dev-python/toml/Manifest3
-rw-r--r--dev-python/toml/toml-0.10.2-r1.ebuild48
-rw-r--r--dev-python/toml/toml-0.10.2.ebuild4
3 files changed, 52 insertions, 3 deletions
diff --git a/dev-python/toml/Manifest b/dev-python/toml/Manifest
index 607f840ce11a..72880c319c2d 100644
--- a/dev-python/toml/Manifest
+++ b/dev-python/toml/Manifest
@@ -1,4 +1,5 @@
DIST toml-0.10.2-1.tar.gz 23325 BLAKE2B dedab7d08dadca963e62d64e9108e254dd73b78761985faa892792823027befc6473ae02c35c275a216b4544d1af8776afa78e39c63c95eb856e2bccf1de49c4 SHA512 5c706a3ae336e6b29bdce9752b91c677f7610cbcc1af4169cc24779e248031406cd19ac367725b2aa7903e4b1db71fa59255238c0270b2c146fd5d7e12d9a5da
DIST toml-test-280497fa5f12e43d7233aed0d74e07ca61ef176b.tar.gz 19593 BLAKE2B e9deba7c5d1eea7bd87fcf5e5c74bda4c2b9e9686e597e3ad51516f60eb8d192fb01d052ac57729c6f0851e2715cc6409a904affd637c9b099cabc1b12ad5d52 SHA512 7bd69b8c14f09bf431094b52d988eb233922527719ba5047ff769d2e709c2039fb6fb1c8144e630ad2a58835d19e0e4cc51433a427596d37f8eccb6d73d7e5c0
-EBUILD toml-0.10.2.ebuild 1073 BLAKE2B 3403c0c958f17e76f1351345460f3bcc4eb3d858cfcec814b46ca79f80dde049c661a72d2f5d613d5a5b12bd7e9c606254fb851d2814102c14457a39fcb99568 SHA512 914da1783d9891cb93942e9f45ae9e815c41b413a42652fe59e9f35686aea543eed2c27a2c8cbd96cddd9577759e1bededfddc16429d9037410f82dfeb4a5fda
+EBUILD toml-0.10.2-r1.ebuild 1095 BLAKE2B 7a8a2b12555aa358b6d2d3ee161532accafb036562bd72b596d9ccd4fedf710fabedc2e931ade256e76dc2cd3c42378f46aeaa7ccd81cdd8cd32b91145847db9 SHA512 d78095161078e63d18f218836845aef38e8eb0c3eb08e13ce03a86c2e30b6f299bf40503787bd69b47466f60e5e85ab68e7856481f007bebcf35589da3bf255b
+EBUILD toml-0.10.2.ebuild 1080 BLAKE2B 7356eeb13d8cf80f82d2ade781d99a6243e60661150b50006b47b85822c761790ab4e2c9c4ba3a500fd137cbc432fc17053f38efcdce66b55d8ed8fd57ef1b4d SHA512 7aef770ef12ecabe9ee703b14aecd44c6e82c82d339447c53b8b32907b6d87ef2fc9bd7d21dcd5f69eafce47aa04038fe3c05648e7c2b9baf0f21634bb740cae
MISC metadata.xml 381 BLAKE2B 2f26693e1f2db544e88e909a23330671d311aec78a8cadc2b53808dd1d639ddb806d1a5e05ca68c93f70d4a8e49a7797fc1c7dd81914b323a4399583cc461f3a SHA512 002007822c8760366eb26599d01e37070904bc4557b218f1bf35774350422f300334dc1d40945adeaa97b4f5ba97ef762ec0717a7b311fb24215782df149b880
diff --git a/dev-python/toml/toml-0.10.2-r1.ebuild b/dev-python/toml/toml-0.10.2-r1.ebuild
new file mode 100644
index 000000000000..3485279561e4
--- /dev/null
+++ b/dev-python/toml/toml-0.10.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+TOML_TEST_VER="280497fa5f12e43d7233aed0d74e07ca61ef176b"
+
+DESCRIPTION="Python library for handling TOML files"
+HOMEPAGE="
+ https://github.com/uiri/toml/
+ https://pypi.org/project/toml/
+"
+SRC_URI="
+ https://github.com/uiri/${PN}/archive/${PV}.tar.gz -> ${P}-1.tar.gz
+ test? (
+ https://github.com/BurntSushi/toml-test/archive/${TOML_TEST_VER}.tar.gz
+ -> toml-test-${TOML_TEST_VER}.tar.gz
+ )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test; then
+ mv "${WORKDIR}/toml-test-${TOML_TEST_VER#v}" "${S}/toml-test" || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/toml/toml-0.10.2.ebuild b/dev-python/toml/toml-0.10.2.ebuild
index c903925b85f7..c9dad0c3e918 100644
--- a/dev-python/toml/toml-0.10.2.ebuild
+++ b/dev-python/toml/toml-0.10.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
@@ -18,7 +18,7 @@ IUSE="test"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
BDEPEND="
test? (