summaryrefslogtreecommitdiff
path: root/dev-python/toml/toml-0.10.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/toml/toml-0.10.2.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/toml/toml-0.10.2.ebuild')
-rw-r--r--dev-python/toml/toml-0.10.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/toml/toml-0.10.2.ebuild b/dev-python/toml/toml-0.10.2.ebuild
new file mode 100644
index 000000000000..2e0e4cab9bb6
--- /dev/null
+++ b/dev-python/toml/toml-0.10.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+TOML_TEST_VER="280497fa5f12e43d7233aed0d74e07ca61ef176b"
+
+DESCRIPTION="Python library for handling TOML files"
+HOMEPAGE="https://github.com/uiri/toml"
+SRC_URI="https://github.com/uiri/${PN}/archive/${PV}.tar.gz -> ${P}-1.tar.gz
+ test? ( https://github.com/BurntSushi/toml-test/archive/${TOML_TEST_VER}.tar.gz -> toml-test-${TOML_TEST_VER}.tar.gz )"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ' 'python*')
+ )"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test; then
+ mv "${WORKDIR}/toml-test-${TOML_TEST_VER#v}" "${S}/toml-test" || die
+ fi
+
+ distutils-r1_python_prepare_all
+}