summaryrefslogtreecommitdiff
path: root/dev-python/tokenize-rt/tokenize-rt-5.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-05 13:19:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-05 13:19:37 +0100
commitd03ec6c0e9c1683a824ce77667440dcb4a13974e (patch)
treea6d1dcba1ebf79b5ab9a81588f2e3dd4ca16cb57 /dev-python/tokenize-rt/tokenize-rt-5.0.0.ebuild
parent315f94518df5e89b0990f56d7200f52d67aeec51 (diff)
gentoo auto-resync : 05:10:2022 - 13:19:37
Diffstat (limited to 'dev-python/tokenize-rt/tokenize-rt-5.0.0.ebuild')
-rw-r--r--dev-python/tokenize-rt/tokenize-rt-5.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/tokenize-rt/tokenize-rt-5.0.0.ebuild b/dev-python/tokenize-rt/tokenize-rt-5.0.0.ebuild
new file mode 100644
index 000000000000..89d0b71b347f
--- /dev/null
+++ b/dev-python/tokenize-rt/tokenize-rt-5.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around the stdlib 'tokenize' which roundtrips"
+HOMEPAGE="https://github.com/asottile/tokenize-rt"
+SRC_URI="
+ https://github.com/asottile/tokenize-rt/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest