summaryrefslogtreecommitdiff
path: root/dev-python/tld/tld-0.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-28 10:03:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-28 10:03:38 +0000
commit24a48769f03b243065aec42c384c39a2d2306964 (patch)
tree6ee4e01247ea4cbdae0b2c9e6b88d86658fae0d3 /dev-python/tld/tld-0.13.ebuild
parent87f37a073fb5c2e1f6ebc780e60cdbdd2c583860 (diff)
gentoo auto-resync : 28:02:2023 - 10:03:37
Diffstat (limited to 'dev-python/tld/tld-0.13.ebuild')
-rw-r--r--dev-python/tld/tld-0.13.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/tld/tld-0.13.ebuild b/dev-python/tld/tld-0.13.ebuild
new file mode 100644
index 000000000000..cdcf22f36571
--- /dev/null
+++ b/dev-python/tld/tld-0.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract the top level domain (TLD) from the URL given"
+HOMEPAGE="
+ https://github.com/barseghyanartur/tld/
+ https://pypi.org/project/tld/
+"
+SRC_URI="
+ https://github.com/barseghyanartur/tld/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/Faker[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' pytest.ini || die
+}